When I'm trying to generate iOS mobile application which uses Anyline plugin (https://github.com/Anyline/anyline-ocr-cordova-module), I am getting this error:

Error installing Cordova plugin: io-anyline-cordova. A specific CocoaPod requires a higher minimum iOS deployment target. Set it in the Extensibility Configurations property of your home module.

I have ZERO knowledge about iOS, but after some searching, my understanding is that the version must be 8.1 (because there is this line in plugin.xml:

        <!-- Anyline Framework & Resource Bundle CocoaPods -->
        <framework src="Anyline" type="podspec" spec="~> 8.1"/>

), or maybe 9.0, or maybe 9.2.

I have added this to extensibility configuration both to the mobile application and to the plugin:

"preferences" : {
        "ios": [{
            "name": "platform :ios",
            "value": "9.2"
        }]
    }

I have also tried this:

            "name": "deployment-target",
            "value": "10.0"

But the error is still the same. Can someone advise, hot to set it up?


Hey Igor,

We'll try to help you. Can you please check which version of the MABS you're using?

Cheers!

Armando Gomes wrote:

Hey Igor,

We'll try to help you. Can you please check which version of the MABS you're using?

Cheers!

I have it set as "Always use the latest version available", and in the dropdown the latest is 4.1 (beta).

Thanks for the answer. I'm looking at the git repo that you linked and I get this:


<!-- Anyline Framework & Resource Bundle CocoaPods -->
<framework src="Anyline" type="podspec" spec="~> 9"/>


Which doesn't seem to match what you posted before. As soon as I possibly can, I'll take a look at that repo on a Mac and see what's going on with the iOS sources.

Hopefully, in the meantime, maybe someone else can provide further help.

Cheers!

Armando Gomes , there was another release after I posted this, 9.0.

I have also reported this to support, I think there is 99% probability that this is OutSystems issue (or at least some hidden feature which I don't know how to involve).



Hi, was this error resolved? If so, may you point me to the solution?

No, it was not. I wrote to support but they are asking me for million details and I don't have time for it now. :)