[InAppBrowser Plugin] Unable to open mobile camera in inapp browser
Question
Forge component by OutSystems R&D

We are trying to access inbuilt camera from inside the InAppBrowser for a mobile app using Outsystems. Camera is not getting opened in InAppBrowser. When we replaced InAppBrowser with system browser(chrome in Android device), camera is getting loaded. Can somebody please suggest an alternative way to achieve this?

Hi Paul,

Why do you need to open camera inside the browser? Can't you use the Camera Pugin?


Regards,

Tiago

Tiago de Resende wrote:

Hi Paul,

Why do you need to open camera inside the browser? Can't you use the Camera Pugin?


Regards,

Tiago

Hi Tiago de Resende,


We are developing a video chat module in our application. For that we need to open camera from inside the browser(not system browser). Camera is loading in the system browser. But for the application purpose, we need to use InAppBrowser.


Thanks and best regards,

Paul


Hello guys,

Do you have any ideia how to resolve this? i'me having the same issue! I need to take a picture inside the InAppBrowser, do you have any ideia how can i do this?


Cheers,

Gustavo Gaspar

Does anyone have a solution to this? I need the same for the Stripe onboarding process which uses the camera to register identity documents. In iOS the inApp browser asks if you want to allow, in Android it just doesn't work.

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.