Hi,

I am currently trying to implement the Hotjar features (https://www.hotjar.com/) so that I can track users journeys on my website to make recordings and heat maps.

The Hotjar website asks that a short JavaScript expression is added to the header of the website.

To do this I just made a web block with the code and added it to the layout web block in the Header Placeholder. 

When I run the verification on the Hotjar website I get the notification telling me that the installation was a success. 

However when I close this window and start using the website to see what is being tracked, Hotjar keeps telling me that I need to verify the installation before it will allow me to start creating recordings, heat maps and so on...

Is this an issue on my end with how I set it up in Outsytems or should I make contact with the Hotjar support?

Many Thanks

Peter



Hello Peter,


Does the browser inspect tools are showing any errors?

Also can you check Service Center's logs for any error messages and Hotjar log (if any) for errors as well?

Jay Santos wrote:

Hello Peter,


Does the browser inspect tools are showing any errors?

Also can you check Service Center's logs for any error messages and Hotjar log (if any) for errors as well?

Hello Jay,

I had a look at the browser HTML and the JavaScript has been added.

Header has this 


And the body has this code 


There doesn't seem to be any errors in the Service Center Logs 

Thanks

Peter




Hi Peter,

I have added hotjar script in a site property and included it in header component and it's started tracking for my application. 

It did not tracked first when I copy the java script which has multiple lines into site property, I had manually deleted all lines breaks of script and made it into single line and it started tracking. May be this trick can help you, I don't know why it did not tracked with multiple lines in the script and why it tracked with single line.


Thanks,

Siva