Outsystems Demo App - Smart power error

Hi everyone, I have a problem with Outsystems Demo app - Smart power. When I open Smart Power Backoffice on web browser, I click Click to Bootstrap button. There is a error show up "SmartPowerVersion Action is incompatible with the SmartPower module definition. Please update it."


I have no idea how to fix this error.  I have already update all module related with "Smart Power",  please advice, Thanks


Hi Test Ac,

This typically means you need to refresh and republish all producers and consumers, in that order. I've never seen that app, but it's an error that has nothing to do with the app per se. It's a generic error that's triggered when the deployment (publishing) has gone wrong somewhere.