sessionState timeout applied via Factory Configuration Not Working

Dear All,

We are trying to set the session idle time out for our web application using the Factory configuration.

We created the shared configuration below and associated the same with all the modules of the applications. Republished the application and could see that all modules web.config were modified upon republish and sessionState is showing timeout attribute correctly. However the application is timing out,  even if we leave the application idle for a day.

Could you please advise how can this be made working?


Thanks,

Zubair

Shared Configuration:

<?xml version="1.0" encoding="UTF-8"?>
<xsl:stylesheet version="1.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform">
    <xsl:output method="xml" indent="yes" encoding="UTF-8"/>
    <xsl:template match="@*|node()">
        <xsl:copy>
            <xsl:apply-templates select="@*|node()"/>
        </xsl:copy>
    </xsl:template>
    <xsl:template match="/configuration/system.web/sessionState">
        <xsl:copy>
            <xsl:attribute name="timeout">2</xsl:attribute>
            <xsl:apply-templates select="@*|node()"/>
        </xsl:copy>
    </xsl:template>
</xsl:stylesheet>





Also, the session timeout seems to be in minutes. In this case, your default session timeout is being set to 2 minutes...

Dear Eduardo,

Yes I followed all the steps mentioned in the following article and for testing purpose I am setting timeout to 2 mins.

Thanks,

Zubair


Eduardo Jauch wrote:

Hi,

Did you follow all the steps from here?

https://www.outsystems.com/forums/discussion/34866/how-to-change-the-session-timeout-in-factory-configuration/

Cheers



So, your application is not timing out in 2 min? :o

Solution

Dear Eduardo,

We could identify the issue and session timeout is working now. The issue was that login screen has RememberLogin variable which was defaulted to true though on screen it was hidden hence the browser seems to store the credentails in cache and after 2 minutes it was creating a new session with cached information. After setting RememberLogin to false the timeout applied via factory configuration is working fine.

Thanks for your help.


Regards,

Zubair

Eduardo Jauch wrote:

So, your application is not timing out in 2 min? :o



Solution

Ah! Never remember the "Remember me"... haha
Yes, it will make you start a new session right away, and will keep all the values. :)