Only some columns show data when bootstraped from excel

Only some of the columns from my excel sheet are showing up in my table. Even an attribute marked mandatory is showing up blank. I have checked that the names of the headers in excel match the attribute names exactly and that the excel file is closed when i bootstrap the data. There are no empty cells in my excel sheet either. Any help would be greatly appreciated!

Hi,

Did you try debugging the process and see what happens during the import? It might give you some hints on what goes on.

Menno

# is it a formula?

# do you assign a math formula to a structure attribute of type text?

hello can you provide your oml and excel to check what is happening with the bootstrab action.

Carlos Diogo Lima Gonçalves wrote:

hello can you provide your oml and excel to check what is happening with the bootstrab action.

Here is the excel file I am using.


Anna Barrett wrote:

Carlos Diogo Lima Gonçalves wrote:

hello can you provide your oml and excel to check what is happening with the bootstrab action.

Here is the excel file I am using.


Here is the oml


Anna Barrett wrote:

Anna Barrett wrote:

Here is the oml


i just bootstrap the excel you send me in the oml and everything seems ok can you send me the oml that have that screen with the table to see what is in the jobnum expression.


Carlos Diogo Lima Gonçalves wrote:

Anna Barrett wrote:

Anna Barrett wrote:

Here is the oml


i just bootstrap the excel you send me in the oml and everything seems ok can you send me the oml that have that screen with the table to see what is in the jobnum expression.




Hi Anna,

The oml you sent does not have the page you showed in the picture above.

Cheers.

Hi Eduardo, 

It should be on the Receiving webpage.

Anna Barrett wrote:

Hi Eduardo, 

It should be on the Receiving webpage.


This is the receiver screen the agregate inside does not have the entity "parts" (table that was in the excel) inside, only "Location".

As Carlos pointed, this screen is not the same as you showed before...

Carlos Diogo Lima Gonçalves wrote:

Anna Barrett wrote:

Hi Eduardo, 

It should be on the Receiving webpage.


This is the receiver screen the agregate inside does not have the entity "parts" (table that was in the excel) inside, only "Location".

So I remade the Parts table and the data is showing up on the preview but when I open in the browser it says "No parts to show..."

The Preview, if you're talking about the preview of the screen in the SS, will show example data.

In run time the data to be shown will depend on the joins, filters, etc. you have.
Check with debugging if you are using in the aggregate the values you think you need and if the aggregate gives something (a misplaced inner join can kill your output depending on your data as easily as a fault filter).

Cheers.

can you provide that oml with the preparation and the table?

I think I'm having troubles with my filters. I can now see the data on the browser page but I'm still having the problem where the PO and Part Number are showing but no other fields are complete. Here is the oml with the table and preparation

Need "%"+Part.PO+"%" if you want to do a partial filter else you should not use "Like" but "="


Edit: and it is in the wrong order it shoudl be (Part.PO like "%"+PONumSearch+"%")
Because what is partial is the filter (PONumSearch) not the atribute in the table (Part.PO).



and this is the test i did with  your aggregate in a screen empty screen what is the field that not appear correctly?

PO and PartNum show correctly on my screen. Part Type, Job Num, Section and location do not show any info. Yes using the partial filter is what I wanted!

Hi Anna,

First thing.

Your module should have (probably) the property UserProvider set to Users (not Current Module as it is set).
This difference can cause problems with data visualization...

Other than that I can't find other problems... 

Cheers.

ok lets try other thing can you print screen your data base in 

Data > WarehouseManagement_Core > Part > Right-Click > View Data


Make sure you have no filters there. Print what you see there please.



Carlos Diogo Lima Gonçalves wrote:

ok lets try other thing can you print screen your data base in 

Data > WarehouseManagement_Core > Part > Right-Click > View Data


Make sure you have no filters there. Print what you see there please.



I have tried deleting the bootstrap action and redoing it. Do you think that would help?

Eduardo Jauch wrote:

Hi Anna,

First thing.

Your module should have (probably) the property UserProvider set to Users (not Current Module as it is set).
This difference can cause problems with data visualization...

Other than that I can't find other problems... 

Cheers.

Where can I go to change that setting?


you have no data on that fields in the data base.

do delete the data you need to go to the core open an advance query


and write this (fastest way)

Click test button (bottom left) this will return this error



Dont mind it the data will be deleted then delete the advance query you created and publish again. (when you publish the bootstrap will run again and check if the data base is empty in case of beeing true he will add data again).


After this repeat the process that see if there is data on table Parts.

I think I followed all your instructions and when I go to Data>Part>View Data there are no records to show. 

Solution

Anna Barrett wrote:

I think I followed all your instructions and when I go to Data>Part>View Data there are no records to show. 

ok the delete part worked now you need to load data again.



make sure you have the timer like this and the function in login "BootstrapPart" like it was generated. And publish the core module


Solution

Carlos Diogo Lima Gonçalves wrote:

Anna Barrett wrote:

I think I followed all your instructions and when I go to Data>Part>View Data there are no records to show. 

ok the delete part worked now you need to load data again.



make sure you have the timer like this and the function in login "BootstrapPart" like it was generated. And publish the core module


Yes! That worked! all my data is showing now! Thank you so much


uff glad i could help :)



Anna Barrett wrote:

Where can I go to change that setting?

In your core module, select the root (with module name) in the tree view (any layer, data, logic, interface, does not matter).
In the properties panel, you will see the property User Provider. Set it to Users.

Cheers.