show web application inside Iframe blocked cookies

hi there

i have website like https://domain2 it also works like https://domain2 (both http and https are active and user can use any of them)  i want to show outsystems 10 web application like https://domain1/myweb inside Iframe but i have problem asp net Postback stop working inside iframe when clicking on button show error "Cannot decrypt the content" or "Error Deserializing ViewState of page"  (in some browser works but in IE10 and safari stop working) it seems it's security problem that browser do not allow to set cookie inside iframe how can i resove this problem any solution?

i have disabled cookies in webapplication espace but do not worked again and outsystems try to set another cookies like "pageLoadedFromBrowserCache=true;RT=s=1558442964778&r=***PriceCalculator.aspx"

update 1:

i found problem with adding "RT" cookie and "pageLoadedFromBrowserCache" cookie , i could disable RT cookie but i do not know how disable "pageLoadedFromBrowserCache" cookie.

regards,

Omid

Have you checked the browser tools console to see if there are any errors listed?

A quick web search turned up this, which suggests that it might be a trust issue with IE10 and Safari:

https://stackoverflow.com/questions/389456/cookie-blocked-not-saved-in-iframe-in-internet-explorer

and https://stackoverflow.com/questions/32713992/safari-does-not-allowed-cross-domain-cookies-in-iframe

Also:

https://www.mendoweb.be/blog/internet-explorer-safari-third-party-cookie-problem/

which confirm that this is an issue with those browsers blocking third-party cookies, and really has nothing to do with OutSystems specifically. There are workarounds listed in the above posts.

G. Andrew Duthie wrote:

Have you checked the browser tools console to see if there are any errors listed?

A quick web search turned up this, which suggests that it might be a trust issue with IE10 and Safari:

https://stackoverflow.com/questions/389456/cookie-blocked-not-saved-in-iframe-in-internet-explorer

and https://stackoverflow.com/questions/32713992/safari-does-not-allowed-cross-domain-cookies-in-iframe

Also:

https://www.mendoweb.be/blog/internet-explorer-safari-third-party-cookie-problem/

which confirm that this is an issue with those browsers blocking third-party cookies, and really has nothing to do with OutSystems specifically. There are workarounds listed in the above posts.

Hi Andrew

i read all articles and i know some of them worked but they are not nice way and if i could prevent cookie pageLoadedFromBrowserCache everything was ok for me and my web app could work,my web app do not need any cookie and this cookie added by outsystems i do not want it , have any idea?

Regards,

Omid


Disabling the cookies will likely result in undesired effects on your OutSystems application.

You are trying to treat the symptom, rather than addressing the underlying problem, which is how IE10 and Safari behave with respect to third-party cookies. 

More information on cookie use in OutSystems applications is available at: https://success.outsystems.com/Support/Enterprise_Customers/Maintenance_and_Operations/Cookie_Usage_in_Web_Applications