[Siri Shortcuts Plugin] Failed to generate iOS build

Forge Component
(0)
Published on 15 Mar by Bruno Martinho
0 votes
Published on 15 Mar by Bruno Martinho

Hi,

I am having issues in generating the iOS build using this plugin.

In error logs it says :
Error: Version of installed plugin: "cordova-plugin-add-swift-support@1.7.0" does not satisfy dependency plugin requirement "cordova-plugin-add-swift-support@^1.7.2". Try --force to use installed plugin as dependency.

Can anyone please help me in this regards.


Thanks

Anybody facing this issue ?

Can anyone please help me in this regards.

Hello.

I've just built an application with the plugin.

What version are you using?

Shreyas Bhondve wrote:

Hi,

I am having issues in generating the iOS build using this plugin.

In error logs it says :
Error: Version of installed plugin: "cordova-plugin-add-swift-support@1.7.0" does not satisfy dependency plugin requirement "cordova-plugin-add-swift-support@^1.7.2". Try --force to use installed plugin as dependency.

Can anyone please help me in this regards.


Thanks

Hi Shreyas,

Can you try to change the  MABS version to not use 5.0 Beta (for ex: 4.2) to generate the build


https://success.outsystems.com/Documentation/11/Delivering_Mobile_Apps/Generate_and_Distribute_Your_Mobile_App#choosing-the-mabs-version-to-build-your-mobile-packages


If you are using your personal environment then you'll not be able to see/change your MABS version, for Outsystems forces all the personal environments to use the latest MABS version.


  • MABS 5.0 uses the Android API level 28, so you will be able to continue submitting your Android apps to Google Play, in line with the recent Google announcement.

  • MABS 5.0 uses Cordova Android engine 8.0.0 for Android apps. It is highly recommended that you revise your plugins to be compatible with this version.

  • MABS 5.0 now uses version 28 of Android support libraries.

  • With this release, we have dropped support for Android 4.4.


Ref Link :

https://success.outsystems.com/Support/Release_Notes/Mobile_Apps_Build_Service_Versions

https://success.outsystems.com/Support/Release_Notes/Mobile_Apps_Build_Service#MABS_Version_5.0


Try to change the MABS & generate the build, If it works then do report to the Owner of the plugin that it doesn't support on latest MABS.


Hope it helps,

Assif


assif_tiger wrote:

Shreyas Bhondve wrote:

Hi,

I am having issues in generating the iOS build using this plugin.

In error logs it says :
Error: Version of installed plugin: "cordova-plugin-add-swift-support@1.7.0" does not satisfy dependency plugin requirement "cordova-plugin-add-swift-support@^1.7.2". Try --force to use installed plugin as dependency.

Can anyone please help me in this regards.


Thanks

Hi Shreyas,

Can you try to change the  MABS version to not use 5.0 Beta (for ex: 4.2) to generate the build


https://success.outsystems.com/Documentation/11/Delivering_Mobile_Apps/Generate_and_Distribute_Your_Mobile_App#choosing-the-mabs-version-to-build-your-mobile-packages


If you are using your personal environment then you'll not be able to see/change your MABS version, for Outsystems forces all the personal environments to use the latest MABS version.


  • MABS 5.0 uses the Android API level 28, so you will be able to continue submitting your Android apps to Google Play, in line with the recent Google announcement.

  • MABS 5.0 uses Cordova Android engine 8.0.0 for Android apps. It is highly recommended that you revise your plugins to be compatible with this version.

  • MABS 5.0 now uses version 28 of Android support libraries.

  • With this release, we have dropped support for Android 4.4.


Ref Link :

https://success.outsystems.com/Support/Release_Notes/Mobile_Apps_Build_Service_Versions

https://success.outsystems.com/Support/Release_Notes/Mobile_Apps_Build_Service#MABS_Version_5.0


Try to change the MABS & generate the build, If it works then do report to the Owner of the plugin that it doesn't support on latest MABS.


Hope it helps,

Assif


Hi Assif,

Sorry for late reply.

I tried using the earlier version of MABS i.e v4.2, still I am not able to generate the build.

Attached is the logs file for your reference.

Regards


Bruno Martinho wrote:

Hello.

I've just built an application with the plugin.

What version are you using?

I am using the latest version of plugin i.e v1.0.0