After v11 upgrade ... "The remote server returned an error (401) Unauthorized"
Question

Hi all !


I have a problem after the upgrade from v10 to v11. We upgraded all our infrastructure (Dev server / Lifetime server / Prod server) ... everything works. We upgraded / republished all the applications / modules.

Now, when we click on the "New application" button we have the message "The remote server returned an error (401) Unauthorized".

This happens even with the personal users accounts (developers), even with the admin account.

What are we missing ?

Solution

Yes, I solved with the Support ... I opened a case


It was a pemission problem ... I make a copy / paste of our activity (maybe it can help you):


You can find below a summary of the troubleshooting we performed during our call:

    We started by reproducing the problem of attempting to create a new application in Service Studio and we immediately obtained the HTTP 401 Unauthorized error;
        This was tested from outside the server machine and also from inside the server connected through "localhost";
    There was no error logged in the Error logs of Service Center nor any call in the Integration Logs;
    From the error in Service Center, we could see that the error was being triggered when calling and exposed REST service from a System Component called Template Manager;
        This web service uses Basic Authentication and the authentication token is sent on the headers of the request;
    By enabling the IIS feature Failed Request Tracing, we were able to validate that the request from Service Studio did contain the Basic Authentication header, but the error was happening nonetheless;
    After analyzing the IIS Authentication on the Template Manager site, we verified that this site had the Basic Authentication enabled. After disabling it, we were able to create new applications;


It seems that the Template Manager inherited the Authentication configurations from the Default Web Site because it is a new module. Modules that already existed remained with the current configurations.

You can also revert the changes we performed during the troubleshooting:

    Change the Integration log level of the Template Manager exposed REST service TemplateServices to Default to avoid excessive logging;
    Disable the IIS Failed Request Tracing;


Since the problem is resolved, we'll be marking the ticket as solved.

What are the actual steps to resolve the issue? What are the specific changes in the Integration Log from the Template Manager reset services?

How to disable the Basic Authentication in the Template manager site? 

I recommend opening a ticket with support.

https://www.outsystems.com/SupportPortal/Support/

They will be able to better assist you with this issue since they have better visibility into the environments.

Andres Moreno

Thanks Andres, I'll do that

Luca De Mori wrote:

Hi all !


I have a problem after the upgrade from v10 to v11. We upgraded all our infrastructure (Dev server / Lifetime server / Prod server) ... everything works. We upgraded / republished all the applications / modules.

Now, when we click on the "New application" button we have the message "The remote server returned an error (401) Unauthorized".

This happens even with the personal users accounts (developers), even with the admin account.

What are we missing ?

Hello Luca,

Did you get an answer to your problem? Please I would like to now as I am getting the same error.

Solution

Yes, I solved with the Support ... I opened a case


It was a pemission problem ... I make a copy / paste of our activity (maybe it can help you):


You can find below a summary of the troubleshooting we performed during our call:

    We started by reproducing the problem of attempting to create a new application in Service Studio and we immediately obtained the HTTP 401 Unauthorized error;
        This was tested from outside the server machine and also from inside the server connected through "localhost";
    There was no error logged in the Error logs of Service Center nor any call in the Integration Logs;
    From the error in Service Center, we could see that the error was being triggered when calling and exposed REST service from a System Component called Template Manager;
        This web service uses Basic Authentication and the authentication token is sent on the headers of the request;
    By enabling the IIS feature Failed Request Tracing, we were able to validate that the request from Service Studio did contain the Basic Authentication header, but the error was happening nonetheless;
    After analyzing the IIS Authentication on the Template Manager site, we verified that this site had the Basic Authentication enabled. After disabling it, we were able to create new applications;


It seems that the Template Manager inherited the Authentication configurations from the Default Web Site because it is a new module. Modules that already existed remained with the current configurations.

You can also revert the changes we performed during the troubleshooting:

    Change the Integration log level of the Template Manager exposed REST service TemplateServices to Default to avoid excessive logging;
    Disable the IIS Failed Request Tracing;


Since the problem is resolved, we'll be marking the ticket as solved.

What are the actual steps to resolve the issue? What are the specific changes in the Integration Log from the Template Manager reset services?

How to disable the Basic Authentication in the Template manager site? 

mvp_badge
MVP

Hi Luca,

Just marked your answer as solution for everyone else that get the same problem.

Regards,

Marcelo

In our case, we had a different root cause. Our domain url was accesible from outside web but not from within platform server itself. Only works with private ip or localhost. Issue was that our internal DNS was not configured to resolve this domain.

So one basic thing to check is if you can access the outsystems url (https://<your-env>/servicecenter) without any issues within the platform server and that the certificate should be valid.

We had to change our hostfile to point env hostname to localhost and bypass domain resolution. Permanent solution is to change internal organisation dns settings.

Hello everyone, 

we had the same problem and the resolution was different:


Best regards,

Thanks

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.