[Printer Plugin] Error compiling Cordova plugin: lambda expressions are not supported in -source 1.6.

Forge Component
(2)
Published on 2018-10-08 by Luís Rondão
2 votes
Published on 2018-10-08 by Luís Rondão

Hi,


I'm having this error while generating the application:

"The following errors have occurred:• In Android on 12-06-2019 at 10:05:14 - Error compiling Cordova plugin: de/appplant/cordova/plugin/printer/PrintManager.java:182: error: lambda expressions are not supported in -source 1.6."


Any suggestion of what it might be?


Thanks,

Pedro

Hi Pedro,


I've just tried to generate an App that uses this plugin and it completed without any error.

Since my personal environment did not have the latest version of the platform I've scheduled the update so I can try to generate the App with the latest version.

I'll let you known as soon as I'm able to perform the test using the latest version.


Regards,

Luís Rondão


Taxis Transportes wrote:

Hi,


I'm having this error while generating the application:

"The following errors have occurred:• In Android on 12-06-2019 at 10:05:14 - Error compiling Cordova plugin: de/appplant/cordova/plugin/printer/PrintManager.java:182: error: lambda expressions are not supported in -source 1.6."


Any suggestion of what it might be?


Thanks,

Pedro