[FabricPlugin] Error when generating APP with MABS 5.0

Forge Component
(4)
Published on 2017-10-31 by Experts
4 votes
Published on 2017-10-31 by Experts

Hello,


When compiling an APP with MABS 5.0 i get the following errors related to the Fabric Plugin:

IOS:

The following build commands failed: PhaseScriptExecution Crashlytics /Users/mabs02/Library/Developer/Xcode/DerivedData/XXX/Build/Intermediates.noindex/ArchiveIntermediates/XXX/IntermediateBuildFilesPath/XXX.build/Debug-iphoneos/XXX.build/Script-XXX.sh

(1 failure)


Android:


[2019-06-19T19:18:32.843Z] [ERROR] Unable to locate the application package!
[2019-06-19T19:18:32.844Z] [ERROR] Unable to locate the application package!
[2019-06-19T19:18:32.844Z] [ERROR] Build failed with the following error: An unexpected error has occurred while packaging your application. Please try again. If the problem persists, contact OutSystems Support.


This erros do no occur after removing Fabric Plugin references.


Can you please help?

Hi,

The plugin may not be supported i.e Upgraded to support with MABS 5.0

If you have enterprise account then you can change the MABS to use this or if you are using your personal environment then you'll not be able to see/change your MABS version, for Outsystems forces all the personal environments to use the latest MABS version.


  • MABS 5.0 uses the Android API level 28, so you will be able to continue submitting your Android apps to Google Play, in line with the recent Google announcement.

  • MABS 5.0 uses Cordova Android engine 8.0.0 for Android apps. It is highly recommended that you revise your plugins to be compatible with this version.

  • MABS 5.0 now uses version 28 of Android support libraries.

  • With this release, we have dropped support for Android 4.4.


Ref Link :

https://success.outsystems.com/Support/Release_Notes/Mobile_Apps_Build_Service_Versions

https://success.outsystems.com/Support/Release_Notes/Mobile_Apps_Build_Service#MABS_Version_5.0


Hope it helps

Hello Assif,


The need to upgrade to MABS 5 to continue submitting apps to Android store its the reason i need an update on this Plugin. If it will not be updated it should be marked as obsolete. 


Outsystems has a great challenge in keeping Forge "clean". Mobile Plugin need to have the information about the MABS versions they support

Carlos Alexandrino wrote:

Hello Assif,


The need to upgrade to MABS 5 to continue submitting apps to Android store its the reason i need an update on this Plugin. If it will not be updated it should be marked as obsolete. 


Outsystems has a great challenge in keeping Forge "clean". Mobile Plugin need to have the information about the MABS versions they support

Yep, I do agree with you.

It's hard to identify the plugin MABS unless the user has test it or plugin-owner mention it.

although I post an idea for same.

You can comment on your respective thoughts to support.

https://www.outsystems.com/ideas/6976/field-in-forge-plugin-description-to-specify-the-supported-mabs-version