79
Views
13
Comments
[VisaAPI] Cannot access the certificate resource
Question
Forge component by Barduino
2
Published on 01 Jul 2019

Hi,


I tried to replace your certificate to mine but I got this error:

"Could not access resource 'Certs\cert.p12'. Make sure the referenced resource is not outdated."


The resource is set to deploy to target directory and I cannot get it's contents.

Is there any trick to be able to do it?

mvp_badge
MVP
Rank: #373002

Hi William

I had no issue changing the resource.

Have you perhaps done anything other than Right click-> change resource?

Sometimes a redeploy sorts it out as well?

Hanno


mvp_badge
MVP
Rank: #373002

I see that my resource is set to "Do Nothing" on deploy.

mvp_badge
MVP
Rank: #351

Yes, I just changed the resource.

Also I have tried the deploy to target directory but I did not work as well.

I'm wondering if it could be something regarding my infrastructure of the personal environment.

mvp_badge
MVP
Rank: #373002

Can you delete and try to reinstall the component in your PE?

I have been able to use it in PE and Enterprise environments in the past week...

mvp_badge
MVP
Rank: #351

I did already, it didn't work.

mvp_badge
MVP
Rank: #351

I will try to install it on my enterprise one.

mvp_badge
MVP
Rank: #351

I tried and it did not work too.

mvp_badge
MVP
Rank: #351

If I send you privately my sandbox certificate and my credentials, can you try it there?

mvp_badge
MVP
Rank: #373002

Absolutely.


mvp_badge
MVP
Rank: #351

I've sent you a private message asking to which e-mail should I send it. As it is my credentials for Visa API I don't want to share it here.

mvp_badge
MVP
Rank: #373002

Sure, I understand. I have replied.

Rank: #303

was there ever a solution to this?  I'm seeing the same error with a different resource file in my own module.