Link to new Web Screen (Course: Data Queries and Widgets 2)

Hello all,
I am doing the course "Developing OutSystems Web Applications"
At this moment i can't get a Link widget working to go to a new webscreen.

Destination is set, just like the MoveId (used in the course).
The web screen where it is linked to already exist

Thanks in advance.
Regards,
Sander

Hi Sander, What exactly do you mean with it not working?

Does the link show up in your page?

Does it trigger any error in the console when you click it?

Can you share your espace so we can take a look and help you out?

João Melo wrote:

Hi Sander, What exactly do you mean with it not working?

Does the link show up in your page?

Does it trigger any error in the console when you click it?

Can you share your espace so we can take a look and help you out?

Hi João,
Thanks for your reply.
The link itself appears in the application, see below. It is called "Add" .

This link should make it possible to go to another webscreen. When I click on it, this screen appears. 


Some technical details of the link " add"  

And the webscreen it should go to.
I hope this information is helpful.What exactly is espace? So i can share it.
Gr,Sander

Solution

Hey Sander, yes, it helped a lot!

Actually, there is nothing wrong with your link. The error page you see is the expected behavior when an issue happens within your logic.

In this case, you are already in your destination page (look at the URL), and an error happened in the Preparation.

To see what happened, you can take a look at the Error Log (Service Center), or try to debug your Preparation logic.

Happy coding!

Solution

Hi João,
Thanks for your support. It was indeed an error in the Preparation (SQL-statement). 

Regards,Sander