[Network FileSystem] How to connect to the domain set in Input Parameter?

Forge Component
(6)
Published on 2009-03-17 by Matthias Preuter
6 votes
Published on 2009-03-17 by Matthias Preuter

I am using the FileSystem to access the remote folder.

It seems that it is connecting to the Outsystems server and not the Domain I entered.

When I added the username and password in Operation > Run As, the espace does not load and no error given.

Thank you.

-Edwin

Edwin Siruma wrote:

I am using the FileSystem to access the remote folder.

It seems that it is connecting to the Outsystems server and not the Domain I entered.

When I added the username and password in Operation > Run As, the espace does not load and no error given.

Thank you.

-Edwin


Hi Edwin, I  went through the same process yesterday and runt tino exactly the same problem.
I tried to follow the steps on this article but got no luck. 

However instead of the FileSystems plugin, i used the Network FileSystems plugin which allowed me to pass the credentials as parameters and was sucessful. 


But looking at your question, im under the impression that you already tried that but also did not get the desired results. If that is the case have you tried to map the shared folder inside the server where outsystems is running.

Edwin Siruma wrote:

I am using the FileSystem to access the remote folder.

It seems that it is connecting to the Outsystems server and not the Domain I entered.

When I added the username and password in Operation > Run As, the espace does not load and no error given.

Thank you.

-Edwin


Edwin, Did you add the remote domain user to your OutSystems's IIS_IUSRS group?

Solution

Hi,

Yes, we did add the user to the IIS group.

I ended up using the SFTP component. It is exactly what I needed.

https://www.outsystems.com/forge/component-discussions/32/SFTP


Thank you!


Regards,

Edwin

Solution

Yeah, SFTP is also an option; gladly it worked for you. To be noted, "Network FileSystem" component has not been updated for quite long time.