Problem creating entities (Foreign Keys)

Hello everyone.


I'm having a problem creating entities that never happened to me.


I don't know why, but when I add two attributes of type user identifier to my entity and I try to publish I run into a error.


I already deleted the module and created a new one. I created a new entity and added attributes one by one and testing one by one. When I try to publish the second User identifier attribute to the entity I get the error:


"Upgrade Error
Could not create foreign key constraint. This may have happened because there are 'UpdatedBy' values of entity 'Suppliers' with no corresponding value in entity 'User', or attribute 'UpdatedBy' of entity 'Suppliers' is creating a circular dependency between entities. Check the Error Log for more information."


See the attachment to more details


Notes: 

1- In this module, there were more entities and all of them with these attributes. I had no problem publishing any of them. The error started out of nowhere and I can't understand why.

2- The tests were done on a new module within the same application. In the new testing module (attachment) I changed all the names


Thank you

Hi Pedro,

Which version are you using? Can you share an example module that you can't publish.

Regards,

Marcelo

Hello Marcelo

I´m using version (10.0.1009.0)

I just create a module and one entity. And do not work.

The environment that I´m using is from a company. I´m not allowed to share OML :(

Thanks


Hi Pedro,

Looks that everything is ok. And I can't test it on that specific version. Your best bet is contact support here

Regards,

Marcelo

Hi Pedro, 

I just published an entity with two User Identifiers attributes, both on O10 and O11 and it just worked.
No problems at all...

Can you give a little more detail on the process? There is data? A bootstrap? 

Cheers.

Demon things happen :)


As a last resort, I changed the type of user identifier attributes to any other type (The types were automatically given by the platform). I put it back again to User Identifier and it works :). Weird...


Thank you Eduardo and Marcelo

Cool, it is solved.
Sad we don't know why... :( 

I bet it was a problem with Service Studio... Sometimes it gets a little "wow" and needs to be restarted... rs

Cheers.