Popup Widget displaces disproportionally upon cursor move while mousebutton down.

Dear Community,

I am having some trouble with the PopUpWidget (OutSystems 10).

I have added a gif to illustrate the problem.


In this gif, I click the ‘X’ to close the popup, while keeping the mousebutton down I very slightly move the cursor (1 pixel). 

This prompts the popup window to displace itself. While keeping the mousebutton down, I can move the popup around, like you would be able when clicking any other header.

However, my cursor is no longer on the header of the popup, but 150 pixels above. I know it is 150 pixels because I see this as change as an inline property in the inspector window. However, searching through the application i cannot find where this 150 pixels is defined.

I have no idea why this is happening other than it being a conflicting interaction between the themes in use. I’ve been able to reproduce it by creating a new application with the same themes added. And subsequently fix it, by adding the Liverpool theme. (which is not in use in the application.)

This however does not fix it in the actual application.

Any help is greatly appreciated.


Kind regards,

Niels

Can you share an OML that reproduces the issue? That might help folks who are still on OS 10 help you troubleshoot.

G. Andrew Duthie wrote:

Can you share an OML that reproduces the issue? That might help folks who are still on OS 10 help you troubleshoot.

Hi Andrew, 

Unfortunately I cannot share an OML, atleast not one containing the custom themes of the client. I'll have to see if I can reproduce the issue without those themes.

thanks


niels schaafsma wrote:

Dear Community,

I am having some trouble with the PopUpWidget (OutSystems 10).

I have added a gif to illustrate the problem.


In this gif, I click the ‘X’ to close the popup, while keeping the mousebutton down I very slightly move the cursor (1 pixel). 

This prompts the popup window to displace itself. While keeping the mousebutton down, I can move the popup around, like you would be able when clicking any other header.

However, my cursor is no longer on the header of the popup, but 150 pixels above. I know it is 150 pixels because I see this as change as an inline property in the inspector window. However, searching through the application i cannot find where this 150 pixels is defined.

I have no idea why this is happening other than it being a conflicting interaction between the themes in use. I’ve been able to reproduce it by creating a new application with the same themes added. And subsequently fix it, by adding the Liverpool theme. (which is not in use in the application.)

This however does not fix it in the actual application.

Any help is greatly appreciated.


Kind regards,

Niels


Hi Niels,

I have done what you have stated but I am not following the whole thing.

this is an application link which is made in 10.

https://silkui.outsystems.com/dublinpreview/Layout.aspx


just try the same thing popup with title.

maybe this is the bug.


Regards,

Pankaj