[AppLauncherPlugin] Error: App Launcher Plugin is Unavailable

Forge Component
(5)
Published on 2018-08-10 by Eduardo Jauch
5 votes
Published on 2018-08-10 by Eduardo Jauch

Hi,


I am using App Launcher Plugin to open another app but giving me an Error 'App Launcher Plugin is Unavailable'.


I have installed the application on device without using OutSystems Now or browser and using OutSystems V11.


Regards,

Manthan Shah.

Hi, 

Did you install a new package built after adding the plugin into the application? 

Cheers

Yes I installed the new package. There is a error with the new package if you can update it please do. Please have a look at my observation below:

In the extensibility configuration you have written the following code:


{
    "url": "https://github.com/EduardoJauch/cordova-plugin-app-launcher#0.4.2"
}


but after replacing it with the following the following code:


{
    "plugin":{
        "url":"https://github.com/EduardoJauch/cordova-plugin-app-launcher.git/#v0.4.1"
    }
}


the same is working. I think you should update the extension.


Regards,

Manthan Shah.

Hi. 

Thanks for the heads up. 

I'll check to see what is happening. 

Cheers 

Eduardo Jauch wrote:

Hi. 

Thanks for the heads up. 

I'll check to see what is happening. 

Cheers 

Hope this gets resolved by next update. Can you also check with an ios device?

Hi Manthan,

I don't have (or work with) iOS. As the original plugin (from GitHub) has code for it, I included, but can't really help with it. We have a new team member that works with iOS, but as this is a not paid effort, I can't guarantee when he will be able to do some work on this part.

Regarding the Android part, I'll check what's the problem as soon as possible.

Cheers!