Hello,

Deleting the default Form style from the Form widget causes weird CSS.


The fa-pencil icon is not seen in the service studio or anywhere within my CSS stylesheets. How can I fix this?

Why do you want to delete the default form style? 

Daniël Kuhlmann wrote:

Why do you want to delete the default form style? 

It interferes with the alignment of elements within the form. For example, the input widgets go below the labels instead of next to them. I could use CSS for every element and set the float property but deleting the Form style seemed like the easier fix. Isn't the pencil icon appearing a bug? 


Solution

For sure that the pencil appears looks odd to me.

Wether labels are left, or above can be set as a form widget property Label Position, no need to tweak default styling.


Solution

Hi Lalith Nimmagadda,

The Form widget has a property to select where Labels will be displayed. The pencil style that you're seeing is actually from the Input widget actually... depending on how the user has interacted with the Input it may display a gray pencil, or a gray undo icon. Not sure why you're seeing them like that, but maybe you did a little bit more than remove a style or two? ??

Lalith Nimmagadda wrote:

Daniël Kuhlmann wrote:

Why do you want to delete the default form style? 

It interferes with the alignment of elements within the form. For example, the input widgets go below the labels instead of next to them. I could use CSS for every element and set the float property but deleting the Form style seemed like the easier fix. Isn't the pencil icon appearing a bug? 


Hi Lalith, if you want to have the labels aligned with the inputs of form, you can do that. Change the "label position" property of the form to Left Aligned.

Jorge Martins wrote:

Hi Lalith Nimmagadda,

The Form widget has a property to select where Labels will be displayed. The pencil style that you're seeing is actually from the Input widget actually... depending on how the user has interacted with the Input it may display a gray pencil, or a gray undo icon. Not sure why you're seeing them like that, but maybe you did a little bit more than remove a style or two? ??

I overlooked the label position setting for the Form widget. Changing it to left-aligned fixed the problem. As for the pencil icons, all I did was remove the Form style. Thanks


Lalith Nimmagadda wrote:

Hello,

Deleting the default Form style from the Form widget causes weird CSS.


The fa-pencil icon is not seen in the service studio or anywhere within my CSS stylesheets. How can I fix this?

Hi,

 I am facing the same issue. I can see a pencil beside my textbox. Did you find a way to remove it?

Smriti

Smriti Asthana wrote:

Lalith Nimmagadda wrote:

Hello,

Deleting the default Form style from the Form widget causes weird CSS.


The fa-pencil icon is not seen in the service studio or anywhere within my CSS stylesheets. How can I fix this?

Hi,

 I am facing the same issue. I can see a pencil beside my textbox. Did you find a way to remove it?

Smriti

Yes, try adding the Form style to your form.