[Advanced Amazon S3] How is the URL being returned?
Web icon
Forge component by Ricardo Pereira

We've used both the SaveFile and the FetchFileURL and, even though we can confirm it is correctly uploaded and we can even download it, no URL is being returned in either action's output.

Is this the expected behavior for these and should we use another action to get the file's URL?


João, there should be a "url" property on the output object of the FetchFileUrl action.

If that is not populated with the url of the file, I'll have to dig deeper.

Hi Hanno, we already worked around the problem by using the binary data directly, but yes we had noticed there was a url property in the output but it is always returned as an empty string.

I'm struggling getting the URL to work from within a browser which is to say we successfully get the URL back from the component but when we paste into browser to hopefully view the image, we receive the following message from AWS:

Message : The bucket you are attempting to access must be addressed using the specified endpoint. Please send all future requests to this endpoint.

We've tried changing the endpoint in the URL but nothing works.

The inputs we're providing are:name, bucket and key and then of course the AccessKey and SecretKey.  The URL comes back and looks reasonable which is to say it has a signature etc...

Any help would be appreciated.


Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.