"It was not possible to save the module" prevents Publish, Save and Save as...

Hi all,

I have been working on a project using the outsystems cloud evaluation host. My Service Studio has been open for some days. After some comprehensive refactoring this morning I tried to publish in order to test my code, and got the "File Save / It was not possible to save the module" error. 

I then tried Save and Save As... to save it locally, and initially got the same error and now get a silent failure. Nothing has been saved in my target directory.

One of these attempts gave me access to an error log. 

The log suggests to me that my problem may be connected to the loss of a temporary file. The first lines of this error log are attached below.

Is there anything else I can do to save my morning's work, or am I out of luck?

Cheers - 

Francis.

---

"Service Studio Version: 11.6.2.3878 (build 99912: trunk @ 232869)

Platform Server Version: 11.0.212.0 Internal Version

Service Studio connected to: francis-norton.outsystemscloud.com

ServiceStudio.Presenter.RuntimeImplementation+FullStackException: Exception in thread Main ---> System.IO.FileNotFoundException: Could not find file 'C:\Users\fnorton\AppData\Local\Temp\OutSystemsTemp\2019-10-16 14-45-45 zoZK2f7RaUO4jUrHaY4dUQ\4MtkWYYwiE2E9WpML4bozg.Byte[]'.
   at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
   at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
   at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access)
   at Storage.Read[T](Func`2 reader)
   at ServiceStudio.Model.AbstractImage.SavePropertyElements(IXmlSerializer saver)
   at ServiceStudio.Model.ESpace.Saver.InnerSaveObject(IXmlSerializable obj)"

Hi Francis,

I've had the same problem a few times when I started working with Outsystems. Since then, I've made it an habit to always shut down the Studio whenever I leave my desk, and there's been no re-occurence. 

Now, as to why the Studio  would behave this way, I have no clue...

Serge A.

I can confirm that there is no file "4MtkWYYwiE2E9WpML4bozg.Byte[]" in the named directory, though there are files with similar names.

Hi,

Try refresh the modified references or missing references in order to avoid possible runtime errors.

Hope it helps.


Interesting - when I open Manage Dependencies, for this or any other module, it shows "Fetching data", then "Processing...", then I get "An error has occurred." and the spinning wait pointer, which appears to spin indefinitely.

Hi Francis,

I've had the same problem a few times when I started working with Outsystems. Since then, I've made it an habit to always shut down the Studio whenever I leave my desk, and there's been no re-occurence. 

Now, as to why the Studio  would behave this way, I have no clue...

Serge A.

Thanks Serge - I think that's the answer. 

Found a work-around if you have been doing work and want to save it.  If you remember what you have changed, go back to the development area and open a second instance of that module, delete the components you have changed, then go back to the first instance / version you had issues with, copy those components, then paste them back into the newly opened version.  I was able to save about a day's work that I had done when I ran into this error.  Being able to paste that work from the old instance to a new one saved my bacon and my sanity.  I agree that closing studio before shutting down / hibernating / is better, but if you forget like I did...  ( i had to run an errand at lunch time, and just closed my laptop.  When I opened it again this issue arose...)

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.