Excel export problems (Application)

Hello,


I would like help because I have problems exporting to excel. As below when exporting from excel I see an error message and the excel file is broken.

I've tried several ways of (Mime-Type) and (File Name) but all to no avail.

However when copying the same screen in another application, it works normally, I believe the error is in the application.

Note: I was wondering if they could help me identify where the excel export error "in application" might be causing.


OS version 10 (Web).



thanks in advance, Leonardo Widmar.


Hi Leonardo,

Have you tried exporting in the XLSX format? I believe the RecordListToExcel action only outputs with that format. What happens when you change your filename to Lojas.xlsx?

Hi Leonardo,

It's like Afonso says. Outsystems creates an XLSX.
By the way, the offcial mime-type for xlsx is application/vnd.openxmlformats-officedocument.spreadsheetml.sheet

Regards,
Lennart

Afonso Carvalho wrote:

Hi Leonardo,

Have you tried exporting in the XLSX format? I believe the RecordListToExcel action only outputs with that format. What happens when you change your filename to Lojas.xlsx?

Hi Afonso Carvalho,

Already tried the XLSX format in the file name, but still with the same error, but when copying the same screen in a new application, the export works, I believe the error must be in the application, but I do not know where the application is the mistake.


Lennart Kraak wrote:

Hi Leonardo,

It's like Afonso says. Outsystems creates an XLSX.
By the way, the offcial mime-type for xlsx is application/vnd.openxmlformats-officedocument.spreadsheetml.sheet

Regards,
Lennart

Hi Lennart Kraak,

Already tried this format (File Name / Mime-Type), but still with the same error, but when copying the same screen in a new application, the export works, I believe the error must be in the application, but I do not know which application location is the error.


It could be some issue with the generated module code - it's weird that it starts working once you copy the screen to a different module. Can you try these and see if they generate a working Excel file?

 - Check less attributes in the RecordListToExcel action: just the Loja.PIS attribute, for instance;

 - Try using a structure as an intermediary instead of outputting the Table content directly;

 - Delete the action, publish, and remake it by hand (don't copy paste it).

Afonso Carvalho wrote:

It could be some issue with the generated module code - it's weird that it starts working once you copy the screen to a different module. Can you try these and see if they generate a working Excel file?

 - Check less attributes in the RecordListToExcel action: just the Loja.PIS attribute, for instance;

 - Try using a structure as an intermediary instead of outputting the Table content directly;

 - Delete the action, publish, and remake it by hand (don't copy paste it).


Afonso Carvalho,

I executed all your tips, but it didn't work!

But when generating another application and pasting the screen, the export works.

Hi! 

Just one wild suggestion : 

Go to the service center and publish all the application, if your application depends from other applications publish them before.

Regards