Getting error testing database connection

Hi 

I got error while testing database connection 


Which Outsystems environment you are using Cloud / On premises ?

If cloud are you using external database or outsystems provided database within in cloud environment ?

Farhan Alanazi wrote:

Hi 

I got error while testing database connection 


Hello,

Did you double check the password of the OSADMIN user?

Pay attention to caps.


BR,

Luis


Hi Farhan,

Did you click on "Grant Permissions" button before clicking on "Create/Upgrade Database"?

If you did this step without any errors, then I would encourage you to open the Configuration Tool > Click on File > Generate Platform SQL Script and run it on your database you're trying to configure. After this you can go ahead and click on "Create/Upgrade Database"

Also note that you're trying to install the database on the same machine as your platform server, which is not really recommended unless for specific test purposes.

Hi Farhan,

Please check that the user you logged in to machine in admin or not. 

If not then you don't have permission to create new user.

Please contact to your Network/Administrator team. 

Hope this this will help you.

Regards,
Amreen


Luís Cardoso wrote:

Farhan Alanazi wrote:

Hi 

I got error while testing database connection 


Hello,

Did you double check the password of the OSADMIN user?

Pay attention to caps.


BR,

Luis



Hello Luis,

 If the password is wrong or incorrect it will throw wrong password exception.



Hai


Also please check the server name.


I can see local.host is specified is that correct?


I doubt.


Ajith