Hi ,

 we are Outsystem11 platform server with .NET flavor with IIS.

Error description :

HTTP/1.1 901
Content-Length: 46
Content-Type: text/html;charset=UTF-8
Date: Sat, 11 Jan 2020 08:02:39 GMT
Server: Apache-Coyote1.1

Error invoking API service  Activity timed out


We are facing timeout issue when consuming external REST API.
This API will roughly take more than a minutes seconds.
However, the API call is timing out in 30 seconds.

We are unable to increase the response timeout beyond the 30 seconds even thoughthe response "timeout in seconds" mentioned is 100 seconds.

We have tried the following approach:

1.Use HTTPRequestHandler Set Timeout to 180 seconds.

2.Set the Timeout in Seconds to 180 seconds. (we also tried to decrease thetimeout to for example 1 second to check if this field is working)

 

May I know how to increase the timeout beyond 30 seconds, like where n all do I need to check where this value could have been set like on IIS ?  


Hi Vivek,

HTTPRequestHandler SetRequestTimeOut() is only relevant for HTTP requests.

The second option you tried "Timeout in Seconds" on rest api, is the correct approach and should work,

Did you try to increase it to a longer time than 180 seconds, maybe 180 was just not enough?

Regards,

Daniel

Hi,
I agree with Daniel, and in addition to what he answered if you're consuming a rest service, you can set the timeout per method.

See below image

Hope it helps,
Nuno Verdasca