Cannot login to ServiceCenter

Hi,

I have installed a new Platform Server and and after installation, if  I try to login to servicecenter login, its says "No connection could be made because the target machine actively refused it 127.0.0.1:12000". It doesnt matter what login info I put in. 


Also, what should be my username/password here?

Hi Francisco.

Have you followed the steps in the installation checklist of your version?

It’s an HTML file that is downloaded along with the binaries of the platform server.

if you missed any of those steps you can face different issues.

No. Let me check. What about the login? What should be my login on Service Center?

Hi Francisco,

If it's an on-premise environment, your login for Service Center should be the credentials you have provided in the Configuration Tool during installation.

Also, it looks like port 12000, which is used by the Deployment Controller, is not open. Check your firewall settings.

See documentation here.

Regards,

Nordin

For the Installation checlist, so I need to perform the pre-installation before installing right? What is I installed it already and havent done the pre installation? Do i need to uninstall then do pre-installation then install again?

Francisco, there is an instruction in the checklist to set the password. Don’t worry, follow all the instructions and everything will work.

Nordin Ahdi wrote:

Hi Francisco,

If it's an on-premise environment, your login for Service Center should be the credentials you have provided in the Configuration Tool during installation.

Also, it looks like port 12000, which is used by the Deployment Controller, is not open. Check your firewall settings.

See documentation here.

Regards,

Nordin

Ive open12000 and 12001 already still having the same issue.


Check if the OutSystems Deployment Controller Service is running, as that's the service who listens on port 12000.

Hi,


I have reinstalled again did the checklist. Now the refused connection is gone when logging in. Problem now is it says invalid username and password. Im using the password that was set on Configuration Tool as below:

I tried running COnfiguration Tool serveral times and changing password but still always says invalid username/password

Hi Francisco,

Do you have External Authentication enabled via LifeTime?

If so, you can execute the SQL statement mentioned in the following article in order to reset LifeTime authentication back to the built-in authentication of the platform.

https://success.outsystems.com/Support/Enterprise_Customers/Maintenance_and_Operations/Reset_LifeTime_authentication_preferences

Regards,

Nordin

Nordin Ahdi wrote:

Hi Francisco,

Do you have External Authentication enabled via LifeTime?

If so, you can execute the SQL statement mentioned in the following article in order to reset LifeTime authentication back to the built-in authentication of the platform.

https://success.outsystems.com/Support/Enterprise_Customers/Maintenance_and_Operations/Reset_LifeTime_authentication_preferences

Regards,

Nordin

Hi,

No I dont have. I cancelled Lifetime Installation, so there is no Lifetime installed


Solution

Hi Francisco,

In that case, I had a similar issue a while ago where after successfully installing the platform, we could not login in Service Center with the admin credentials. 

I had contacted OutSystems Support for this and they came up with the following instructions:

Are you able to perform the following steps:

In my case, I had the incorrect .NET Core Bundle installed (version 3.0) where I should have installed .NET Core 2.1 as stated in the installation checklist.

Here is what I did to fix the issue:

Your instructions were very clear and were also part of the solution of our problem.

We had .NET Core 3.0 Bundle installed and the health API URL's resulted in Internal Server 500 errors. So I uninstalled this version.

After that I installed .NET Core 2.1 (from the installation checklist), I performed an iisreset, and retested the health API URL's with success (it returned a health.json file for both requests).

However, I could not login in Service Center after this.

So, I opened the Configuration Tool and re-entered the admin credentials, clicked Apply and Exit and reinstalled Service Center.

After this, the problem was solved and I could successfully login in Service Center again!

Hope this can help you,

Nordin

Solution

Nordin Ahdi wrote:

Hi Francisco,

In that case, I had a similar issue a while ago where after successfully installing the platform, we could not login in Service Center with the admin credentials. 

I had contacted OutSystems Support for this and they came up with the following instructions:

Are you able to perform the following steps:

In my case, I had the incorrect .NET Core Bundle installed (version 3.0) where I should have installed .NET Core 2.1 as stated in the installation checklist.

Here is what I did to fix the issue:

Your instructions were very clear and were also part of the solution of our problem.

We had .NET Core 3.0 Bundle installed and the health API URL's resulted in Internal Server 500 errors. So I uninstalled this version.

After that I installed .NET Core 2.1 (from the installation checklist), I performed an iisreset, and retested the health API URL's with success (it returned a health.json file for both requests).

However, I could not login in Service Center after this.

So, I opened the Configuration Tool and re-entered the admin credentials, clicked Apply and Exit and reinstalled Service Center.

After this, the problem was solved and I could successfully login in Service Center again!

Hope this can help you,

Nordin

OK. Ill try this and will let you know how it goes. Thanks


The above solution fix the issue.

Thanks for letting us know it worked Francisco!