FCK editor image upload

FCK editor image upload


i've been trying to upload a image without sucess.

After selecting the image the progress bar starts but never ends, i think it has something to do with a misconfiguration, since i never defined the directory where images will be saved... but i can't find it in fckeditor.js

Thanks in advance...

Hi Miguel,


To use the upload functionality of the FCK editor I believe you would have to create a connector: 




Tiago Simões


I read that paper still no luck, i wonder if it's something around win7 permissions, since i changed my config.asp and fckconfig.js with almost all the possibilites i can remember.
<br />

EDIT: Ok, apparently i make an advance since there's an error now, and now it surely is about permissions: error 103. Trying to figure it out. I'm using windows7, probably similar with vista... any help would be appreciated ( tired of googling :)
'http://localhost/fck_Editor/fckeditor/editor/filemanager/connectors/asp/image/myimage.png' -- the path of my image is this.

However i don't know the path to put in the config.asp , can someone give me a help ? I tried for example '~/image/' in the path but it doesn't work out.

And in windows7 you have to change the permissions of "running/fck_editor", in order to upload images.
I have the same error...

I suposed that may be related with the new version created by FCKeditor. they may turn off the reporitory server or something like that...

Setting connector to work

Solution that worked for me:
1- Look for file and edit
file: c:\Program Files\OutSystems\Service Center\running\FCK_Editor...\fckeditor\fckconfig.js
edit this 2 vars, from php to asp:      var _FileBrowserLanguage    = 'asp' ;    // asp | aspx | cfm | lasso | perl | php | py
                                                                var _QuickUploadLanguage    = 'asp' ;    // asp | aspx | cfm | lasso | perl | php | py
2-Look for file and edit
file: c:\Program Files\OutSystems\Service Center\running\FCK_Editor....\fckeditor\editor\filemanager\connectors\asp\config.asp
edit: set ConfigIsEnabled  = true

3-Create folder userfiles, and set same permissions folder aspnet_client for example to folder c:\Inetpub\wwwroot\userfiles
Hi João,

Did you keep the value of the line

ConfigUserFilesPath = "/userfiles/"

in "fckeditor\editor\filemanager\connectors\asp\config.asp" unchanged?

Thank you.