Forge Component
(5)
Published on 6 Apr (10 hours ago) by OutSystems R&D
5 votes
Published on 6 Apr (10 hours ago) by OutSystems R&D

Good morning!

I'm trying to create a Reactive Web App in OS11.

The database that has the information needed is in a Google Cloud Environment, so, I created an external database connection.

After that, when I try to drag the entity to the Main Flow to scaffold a new screen, I got the error that the Outsystems UI Reactive theme needed to be updated. Looking for the update, it gave me the warning that my Service Studio version was not compatible with it (my version is 11.6.24). In attach you can check the component updated.

I updated even so, restart the Service Studio and created a new app again.

The error desappeared, but the scaffolding did not work. I tried to create a normal entity and drag it to the main flow and it created the screen successfully, but with the external entities did not work.

Additionally, when I updated the Outsystems UI Reactive component, it appear new errors from the initial theme layouts (incompatibility as shown in attach).


Best regards,

Tiago Rodrigues

Hi Tiago,

Have you tried updating OutSystems UI?
Regarding external entities I believe they need to have an identifier for scaffolding to work.

Cheers,
Tiago Simões

Hi Tiago,


Yes I have updated both OutSystems UI and Outsystems UI Responsive.

Before updating an error appear when scaffolding saying that I needed to update. After updating, the error desappear but nothing happens when dragged and dropped the entity.

In the next images you can see the order of my actions. You can see that I drag the entity but nothing happens.

You can also check that every entity has an identifier.




Hi Tiago,

Could you please go to Help > Give Us Feedback in Service Studio and explain that you are trying to use scaffolding in reactive, so we can take a look at the issue.

Thanks,
Tiago Simões

Yes sure Tiago. 

I already made a support ticket with that. Bruno Mexia is helping me.

Thanks for the help!

Regards