Confused regarding Forge updates

Hi all !

Can you help me to understand something that is not clear for me ?

I have 1 UPDATE in my Service Studio > I click on the bell icon ... I press UPDATE (I'm talking about the "File Upload" version 4.1.2)

I have an alert that shows me that one of my dependency it's not compatible (I'm talking about "FileSystem" 2.0.5)


How can I solve this ? I have to wait for a new "FileSystem" version ? Can I force the installation ?

Hi Luca,

you should update the FileSystem to the latest version and only after install FileUpload.

Regards,

Marceo

Might be worth asking your question in the support forum for the File Upload component:

https://www.outsystems.com/forge/component-discussions/352/File+Upload

Perhaps someone on the team can check the dependency and see if there's a reason it's showing up as not compatible.

Marcelo Ferreira wrote:

Hi Luca,

you should update the FileSystem to the latest version and only after install FileUpload.

Regards,

Marceo

Hi Marcelo,

unfortunately, I already have the latest version of FileSystem ... that's the reason why I have doubts ...


Hi,

In your picture shows that you have the version 2.0.5 and the latest version is the 3.0.3.

Regards,

Marcelo

Marcelo Ferreira wrote:

Hi,

In your picture shows that you have the version 2.0.5 and the latest version is the 3.0.3.

Regards,

Marcelo

I noticed that ... but I don't have any notification regarding FileSytem updates ...


Maybe I have some problems with the versioning of the Espaces (see attached file)


Hi Lucas,

Looks like the 2.0.5 is the version that file upload needs. I recommend you to force install and than update the references of the file upload.

Regards,

Marcelo

Marcelo Ferreira wrote:

Hi Lucas,

Looks like the 2.0.5 is the version that file upload needs. I recommend you to force install and than update the references of the file upload.

Regards,

Marcelo

I tried to delete "FileSystem" application and re-installing the 3.0.3 OAP manually from Service Center.

The systems still tells me that I have the 2.0.5 version installed ...


Solution

Hi,

That version 2.0.5 that the forge is showing is the version that the File Upload uses. File Upload is still using an older version. The way of solving this is force install File Upload and than refresh the dependencies of File Upload.

Regards,

Marcelo

Solution

Marcelo Ferreira wrote:

Hi,

That version 2.0.5 that the forge is showing is the version that the File Upload uses. File Upload is still using an older version. The way of solving this is force install File Upload and than refresh the dependencies of File Upload.

Regards,

Marcelo

Hi Marcelo ... I followed your sugestions ... I republished everything and everything's working !


Thank you !