Accessibility Testing with siteimprove

I have few questions related to accessibility in Outsystems traditional web. As I am using Siteimprove chrome extension to check accessibility in which I am getting errors in Outsystems pattern like in tab i am getting error  "Aria-labelledby" has incorrect (ID) reference.

I also want to know Outsystems web application can be fully accessible and clears all level like level A, level AA, level AAA of accessibility.

It will be helpful if anyone share the way to remove this errors and warning. Below is the link in which I am performing my testing.


http://pankaj-pawar.outsystemscloud.com/Theme/Home.aspx

 

There are several articles on accessbility with OutSystems. Keep in mind that every pattern is probably is not going to be accessbility friendly - that being said, we are continuing to invest and make improvements in that area.  A quick google search brings up a number of articles that might help:


https://success.outsystems.com/Support/Enterprise_Customers/Accessibility/Accessibility_in_OutSystems_Web_Applications

https://www.outsystems.com/blog/posts/building-web-accessibility-barriers-guidelines-standards/


https://www.outsystems.com/learn/lesson/1707/accessibility-with-outsystems/?LearningPathId=0


Stacey

Stacey Levine wrote:

There are several articles on accessbility with OutSystems. Keep in mind that every pattern is probably is not going to be accessbility friendly - that being said, we are continuing to invest and make improvements in that area.  A quick google search brings up a number of articles that might help:


https://success.outsystems.com/Support/Enterprise_Customers/Accessibility/Accessibility_in_OutSystems_Web_Applications

https://www.outsystems.com/blog/posts/building-web-accessibility-barriers-guidelines-standards/


https://www.outsystems.com/learn/lesson/1707/accessibility-with-outsystems/?LearningPathId=0


Stacey


Thanks for your reply.


I already gone through these links.

My question is related to existing wep pattern provided by OS UI.

As I am getting lot of error in tab itself as it is existing component and to resolve all error I need to make clone but I want to know is there any thing which I am missing.

It will be helpful if you check that link and guide me or share me a link which contain Outsystems UI pattern and is fully accessible so I will use in same way.


I am using updated OS UI in OS 11 traditional web.


Hi Pankaj,

Thanks for reporting that issue related to the incorrect reference. We will have a look at it.

Currently, OutSystems UI patterns are compliant with the WCAG 2.0 rules, covering the AA level and we are working towards accessibility documentation and guidelines to help developers create accessibility compliant applications.

All the feedback around accessibility project development will be appreciated to help find points of improvement, create development guides and share best practices.

Smile,

Hi Pankaj Pawar,

That issue was fixed on version 1.8.0 of OutSystems UI Web. This version comes with several Accessibility improvements, as you can see by the change-log:

https://www.outsystems.com/forge/component-versions/4143


Best regards,

Bernardo Cardoso