Why pressing a button behaves different as pressing enter?

Why pressing a button behaves different as pressing enter?

  
Hi

I would like to know why the same button can behave in two ways...

I have only this button in my screen, and one text field.
When I press the button with the mouse, it goes to an action and behaves in a particular way.
But if I'm with the screen open, and I press ENTER, the action is also triggered (as expected) but the result is different... Some AJAX refresh don't work in the first and others work in the second.

So strange... Why is this difference?
I did debug and all seems to go to the same steps..

Oh by the way, I need to put the focus back in the field and I used and expression with "<script>setFocus('wttxtSerialNumber');</script>" and refresh the expression with AJAX widget.. but doesn't work...

Thank you!

Hi Carolina,

 

I suspect that might be an issue in the the default button behavior when the action is Ajax.

If you could submit your eSpace (or a small sample that shows that problem) to our technical support team support@outsystems.com I'm sure they'll be happy to look into it.

 

Cheers,

Tiago Simões

Hi Carolina

 

Are you using Internet Explorer or Firefox? Does it behave the same way on both?

 

I have seen some cases, only in Internet Explorer, where pressing Enter will completely destroy the layout of a page. One simple example is the Service Center home page, where simply pressing Enter in the search button will yield a completely messed up page, whereas clicking the search button will do just fine.

From a brief investigation I have made, it seems to be because Internet Explorer is not submitting everything it should. This seems to be related somehow to the existence of a form without a default button somewhere in the page - for example, the same example I give above will not cause a messed-up page if you do that in the eSpace list page.

 

To see if the problem is the one above in your eSpace, you can:

  - Make the button default in you page (is default property);

  - See if the problem also occurs in Firefox / Chrome / Safari.

 

Please let us know if that worked for you.

 

Cheers,

I ran across the same issue. I use Firefox mostly and never saw the problem until I was watching a user in IE try to enter a search term and press ENTER.  Oops, messed up page and no search performed.

Setting the button as Default fixed the issue.

Thank You,
David
encountered this as well, should be a warning for it imho?