Hi,

I have installed Outsystems V11 in my system and systems having the Microsoft .net framework v 4.6.2.

But when I open the Service studio it gives me error that it requires Microsoft .net framework v 4.7.2

My concern is that I have some restriction that i am not allowed to upgrade that .net framework version from 4.6.2 to 4.7.2. Is there any back door entry so that i can get rid of that error.

Thanks.....   

Hi Rohan,

You cannot. Service Studio needs at least 4.7.2. It's adviced to install the latest version of .NET (4.8).

Hi Rohan,

Kilian is right about the hard requirement of .NET framework version 4.7.2 for OutSystems 11. 

You should take into account that .NET framework 4.8 is only supported from Platform Server 11 Release Oct.2019 CP2 or later.

Regards,

Nordin

Nordin Ahdi wrote:

Hi Rohan,

Kilian is right about the hard requirement of .NET framework version 4.7.2 for OutSystems 11. 

You should take into account that .NET framework 4.8 is only supported from Platform Server 11 Release Oct.2019 CP2 or later.

Regards,

Nordin

Hi Kilian/Nordin,

Reason is that what I have using that old version is that was customized version and that was the only reason.

Any how without upgrading is there any possibility?

Thanks for your comments....


Solution

Hi Rohan,

Unfortunately it is not possible to install two .NET Framework 4.5+ side-by-side (check here for a bit more info).

This means that you cannot run Service Studio 11 without installing .NET Framework 4.7.2+, and you can't do that without replacing your customised .NET Framework 4.6.2.

Hope this clarifies a bit more the issue.

Solution

Without installing .NET Framework 4.7.2, it is not possible to install service studio 11. It is necessary to install that framework. 


Thank you,

Sudip