[CryptoAPI] I am getting error "Array dimensions exceeded supported range." using AES_DECRYPT

Forge Component
(31)
Published on 2019-03-03 by Ricardo Silva
31 votes
Published on 2019-03-03 by Ricardo Silva

I am trying to decrypt the password and sometimes I am getting error "Array dimensions exceeded supported range." using AES_DECRYPT.

Does anyone face the same issue?

Nagarajan Nallamani wrote:

I am trying to decrypt the password and sometimes I am getting error "Array dimensions exceeded supported range." using AES_DECRYPT.

Does anyone face the same issue?

Hi!

What are the values of the inputs when you call the action?
Are you sending correct data? No empty values or with wrong lenght?

Can you provide an example?


Thanks


Luís Cardoso wrote:

Nagarajan Nallamani wrote:

I am trying to decrypt the password and sometimes I am getting error "Array dimensions exceeded supported range." using AES_DECRYPT.

Does anyone face the same issue?

Hi!

What are the values of the inputs when you call the action?
Are you sending correct data? No empty values or with wrong lenght?

Can you provide an example?


Thanks


Hi, 

Thank you for your response.

I am passing the encrypted value which is stored in the table from AES_Encrypt function so I hope wrong length will not be passed. Also checking the empty values.


Hi @Luis,

did you find any solution on this topic? 

Got the same issue.


Best 

Tobias 

I've only seen this error when the value to decrypt was empty.

I know you wrote that you are checking for empty values, but I wanted to reinforce that, in my experience, that is usually the cause.

João is right. Can you also check it?

Hi Joao and Luis,


you are right, the site propery was empty.

Thanks for your help! 

Glad to know! 

BR,

Luis