I can't Insert, Update or Delete data on external tables.

I can't Insert, Update or Delete data on external tables.

  
I am trying to connect to a foreign entity. I can successfully do SELECTs and get data, but I can not insert, update, or delete data. I have tried different extensions. I have tried it where I import the external entity by linked server to the external SQL server. I also tried creating a VIEW in the OS DB to my external table. Same results.

Run time gives me this error -
The operation could not be performed because OLE DB provider "SQLNCLI" for linked server "(null)" was unable to begin a distributed transaction.
OLE DB provider "SQLNCLI" for linked server "(null)" returned message "No transaction is active.".

'Test' in Advanced Query gives me a time out or "Invalid object name 'MISSING_ENTITY_MyTable'.

I can manually do inserts, updates, and deletes via SQL Manager on the OutSystems Platform Server itself, so I do not think it is a permissions issue with the external SQL server.

Please help.

THanks.
Hi, these other posts may help you:

http://www.outsystems.com/networkforums/viewtopic.aspx?topic=error-accessing-foreign-entity

http://www.outsystems.com/networkforums/viewtopic.aspx?topic=problems-with-linked-servers-on-windows-2003