Internal Error: An error occurred in task 'Update meta database model'

Hi,

Today I woke up my personal environment. But when I try to publish a module I always get the same internal error:

An error occurred in task 'Update meta database model':
Object reference not set to an instance of an object.
Details : System.NullReferenceException: Object reference not set to an instance of an object.
   at OutSystems.HubEdition.DeploymentController.Database.DBScriptsExecutor.UpdateDb(String eSpaceName, HEMessageArrayList warnings, ObjectKey eSpaceKey, ObjectKey applicationKey, Int32 eSpaceVersionId, DeployPhase phase, String uniqueId, IDatabaseAccessService databaseAccessService, IIsolatedDbConfigurationService isolatedDbConfigurationService, IApplicationDbConfigurationService applicationDbConfiguration)
   at cs#erqolxha.InnerExecute()
   at OutSystems.HubEdition.ServerCommon.Tasks.AbstractTask.Execute()

Exception Details:
[1] Internal Error: An error occurred in task 'Update meta database model':
Object reference not set to an instance of an object.
Details : System.NullReferenceException: Object reference not set to an instance of an object.
   at OutSystems.HubEdition.DeploymentController.Database.DBScriptsExecutor.UpdateDb(String eSpaceName, HEMessageArrayList warnings, ObjectKey eSpaceKey, ObjectKey applicationKey, Int32 eSpaceVersionId, DeployPhase phase, String uniqueId, IDatabaseAccessService databaseAccessService, IIsolatedDbConfigurationService isolatedDbConfigurationService, IApplicationDbConfigurationService applicationDbConfiguration)
   at cs#erqolxha.InnerExecute()
   at OutSystems.HubEdition.ServerCommon.Tasks.AbstractTask.Execute()
at OutSystems.HubEdition.ServerCommon.Tasks.AbstractTask.Execute()
   at cs#erqolxfs.InnerExecute()
   at OutSystems.HubEdition.ServerCommon.Tasks.AbstractTask.Execute()
   at OutSystems.HubEdition.ServerCommon.Tasks.SequentialTaskRunner.Run()
   at OutSystems.HubEdition.DeploymentController.Tasks.OneClickPublish.OneClickPublishTask.InnerExecute()
   at OutSystems.HubEdition.ServerCommon.Tasks.AbstractTask.Execute()
   at OutSystems.HubEdition.DeploymentController.Compiler.cs#bhihcgjm.cs#rweuvvwj()
   at OutSystems.HubEdition.DeploymentController.Compiler.cs#pwerbjhy(Object fi)
   at OutSystems.HubEdition.ServerCommon.SandboxAwareThreadPool.sc#hjrysmqz.sc#vqskwbxc(Object gd)
   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.QueueUserWorkItemCallback.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem()
   at System.Threading.ThreadPoolWorkQueue.Dispatch()
[2] System.NullReferenceException: Object reference not set to an instance of an object.
   at OutSystems.HubEdition.DeploymentController.Database.DBScriptsExecutor.UpdateDb(String eSpaceName, HEMessageArrayList warnings, ObjectKey eSpaceKey, ObjectKey applicationKey, Int32 eSpaceVersionId, DeployPhase phase, String uniqueId, IDatabaseAccessService databaseAccessService, IIsolatedDbConfigurationService isolatedDbConfigurationService, IApplicationDbConfigurationService applicationDbConfiguration)
   at cs#erqolxha.InnerExecute()
   at OutSystems.HubEdition.ServerCommon.Tasks.AbstractTask.Execute()


Is there somebody with a similar problem and how did you solve this?

Best regards,

Michiel

Hi, 

I heard of someone with this problem. The person is able. To publish through service center. 

I'll ask you to send a feedback through Service Studio, and open a Support case, please. 

Cheers 

Eduardo Jauch wrote:

Hi, 

I heard of someone with this problem. The person is able. To publish through service center. 

I'll ask you to send a feedback through Service Studio, and open a Support case, please. 

Cheers 

Hi, 

I am also not able to publish through service center. I created a support case, hopefully they can help. Thanks for the advice.

Best regards,

Michiel



hello, I get the same error message. I also woke up my profile today.


Greetings

Christopher


Christopher Werner wrote:


hello, I get the same error message. I also woke up my profile today.


Greetings

Christopher



Hi, 

I am also not able to publish through service center. I created a support case, hopefully they can help. Thanks for the advice.

Best regards,

Rajveer


Hi,

I have same issue, tried publishing from Service Center and succeeded, but I can't continue with application development. Service Center is not taking the new changes.

Regards,

Asma

Hi,

For all the people that have the same problem. I created a support ticket and they fixed it.

If you want to know how to make a support ticket: https://success.outsystems.com/Support/Enterprise_Customers/OutSystems_Support/02_How_to_Open_a_Support_Case


Best regards,

Michiel

Hi,

I´m also getting the same error. In my case, I've just woke up me personal environment and it started to give this error every time I try to publish something.

Best Regards,

Paula Sofia Bento.

Paula Sofia Bento wrote:

Hi,

I´m also getting the same error. In my case, I've just woke up me personal environment and it started to give this error every time I try to publish something.

Best Regards,

Paula Sofia Bento.

Hi,

The same happend to me. Just create a support ticket and they will fix it.

Best regards,

Michiel


Hi,

I have the same issue. I resolve this by turn on and save those three security settings for development environment then republish my mobile app again.

It worked for me.

Regards,

Froilan Gimang

Froilan Gimang wrote:

Hi Froilán,

Thanks :) It worked just fine by enabling those security options.

Hi,

I have the same issue. I resolve this by turn on and save those three security settings for development environment then republish my mobile app again.

It worked for me.

Regards,

Froilan Gimang



Solution

You can also try to go to Service Center -> Administration -> Environment Configuration. Toggle "Debug Mode". Click "Save". Toggle it back and press "Save" again.

Solution

Froilan Gimang wrote:

Hi Froilan,

Thanks for your suggestion , it works for my traditional web app.

Hi,

I have the same issue. I resolve this by turn on and save those three security settings for development environment then republish my mobile app again.

It worked for me.

Regards,

Froilan Gimang



Froilan Gimang wrote:

Thanks Froilan, this solved my problem.

Hi,

I have the same issue. I resolve this by turn on and save those three security settings for development environment then republish my mobile app again.

It worked for me.

Regards,

Froilan Gimang


Pedro Borges' answer worked! Cheers

Froilan Gimang wrote:

Hi,

I have the same issue. I resolve this by turn on and save those three security settings for development environment then republish my mobile app again.

It worked for me.

Regards,

Froilan Gimang

I was having the same problem and it worked for me, thanks a lot!


It worked. Thanks a lot!



Froilan Gimang wrote:

Hi,

I have the same issue. I resolve this by turn on and save those three security settings for development environment then republish my mobile app again.

It worked for me.

Regards,

Froilan Gimang



Froilan Gimang wrote:

Hi,

I have the same issue. I resolve this by turn on and save those three security settings for development environment then republish my mobile app again.

It worked for me.

Regards,

Froilan Gimang


Hi Froilan,

    I am meeting the same issue, but this happened when I created a new application so that no secured setting to be changed.

Regards,

Zhou Shuai

Froilan Gimang wrote:

Hi,

I have the same issue. I resolve this by turn on and save those three security settings for development environment then republish my mobile app again.

It worked for me.

Regards,

Froilan Gimang


Thank you for this tip, this saved my day

Froilan Gimang wrote:

Hi,

I have the same issue. I resolve this by turn on and save those three security settings for development environment then republish my mobile app again.

It worked for me.

Regards,

Froilan Gimang

Hi, I got the same problem some weeks ago, and switching that options to ON helped and the problem was resolved. Today I got the same error publishing but when checking that settings, they were all marked ON, like suppose to. I set them OFF and ON again and it worked after that. I just don't know why that bug happen...


Pedro Borges wrote:

You can also try to go to Service Center -> Administration -> Environment Configuration. Toggle "Debug Mode". Click "Save". Toggle it back and press "Save" again.

Thank you for your solution! Works perfectly!