[OUTSYSTEMS].DBO.[OSUSR_] with key 0 was not updated

Hi,

when I try to save the date data it is showing the error OUTSYSTEMS].DBO.[OSUSR_] with key 0 was not updated,

after that error if I refresh it will be saved 

how to fix that , tried debugging could not find it , 

can anyone suggest please 

Thank you ,

Hi Primal Lobo,

Can you share your module? Or some screenshots that show how you built your flow and where you add the values to the entity.

Kind regards,

Remco Dekkinga

Hi,

Perhaps you are trying to update an entity without setting its Id attribute. Check it out to ensure you are defining all necessary values to the record used at Update action.

Regards,

Wilbert Carpi

Remco Dekkinga wrote:

Hi Primal Lobo,

Can you share your module? Or some screenshots that show how you built your flow and where you add the values to the entity.

Kind regards,

Remco Dekkinga


 If select the employee name from the list  and click on the save button it will give the error (OUTSYSTEMS].DBO.[OSUSR_] with key 0 was not updated,) and after refresh the data will be saved.

Hi Primal,

As @Wilbert Carpi said ...please check that which Identifier you are passing to the update action in Save button.



regards,

Amreen 

Hi Primal Lobo,

I agree with the Wilbert Capri and Amreen. Can you check which fields you fill-in in the save action.

When you still face problems and can't find out why, please share an .oml with us.

kind regards,

Remco

Hi Primal Lobo,

Seems like when you are selecting Employee from the list the id corresponding to the employee (which i am assuming coming from User entity) is not setting in the records id attribute or in variable which you are using for update .Pleas debug the employee selection logic from the list if you have any event like on change associated with it and also the save action where you have logic to update the record .


Regards,

-PJ-