Firebase Mobile 1.0.4 with MABS 6.1 - Outsystem 10

Hi, we tried to use Firebase Mobile 1.0.4 on Outsystems 10 with MABS version 6.1 and change Extensibility Configuration to https://github.com/TruewindIT/cordova-plugin-firebase#1.9 . It working fine on Android but on IOS we keep getting an error:


We already contacted OS Support regarding this issue and they recommend to contact the creator of this App. Hope we can get a possitive response on this.

Thank You and Best Regards,

PJ Cezar

Hi,
first of all i would like to give you some advice, when you have doubts about a component, you should ask the question even in the component. Keep showing up here, and you'll get a quicker response from certain component owners.

Another point is, did you see that they in the last version of the component (do you have the latest version?) Say that they already support both the iOS and Android version of MABS 6? They may not support version 6.1.

"Android and iOS builds with MABS 6 are now supported" (info from Firebase Mobile | What’s new (1.0.7)).

And did you check this posts from component support:


I hope this information helps you.

Cheers,
Nuno

Hi Paul John Cezar,

use the latest version as it is without any change in Extensibility Configuration.

And make sure your zip contains the configuration file for iOS as well i.e GoogleService-Info.plist

Your google-services.zip should have both files:

Refer the configuration guide:

https://www.outsystems.com/forums/discussion/43685/configuration-guide/


assif_tiger wrote:

Hi Paul John Cezar,

use the latest version as it is without any change in Extensibility Configuration.

And make sure your zip contains the configuration file for iOS as well i.e GoogleService-Info.plist

Your google-services.zip should have both files:

Refer the configuration guide:

https://www.outsystems.com/forums/discussion/43685/configuration-guide/



Hi,

I already tried this one and give as an error:


so we created ticket for Outsystems Support they recommended to use the lowest version which 1.0.4, but I'm getting error:


That's why we change the Extensibility Configuration from 1.6 to 1.9


Thank You

What was the result when you try with :

FirebaseComponent : 1.0.7

MABS: 6.0 or 6.1

Extensibility Configuration:  https://github.com/TruewindIT/cordova-plugin-firebase#1.9

Let me know... or u can have a trial by above combination

assif_tiger wrote:

What was the result when you try with :

FirebaseComponent : 1.0.7

MABS: 6.0 or 6.1

Extensibility Configuration:  https://github.com/TruewindIT/cordova-plugin-firebase#1.9

Let me know... or u can have a trial by above combination


Hi,


for 

FirebaseComponent : 1.0.7

MABS: 6.0 or 6.1

Extensibility Configuration:  https://github.com/TruewindIT/cordova-plugin-firebase#1.9 


It prompt error: "An unexpected error has occurred while generating your application. Please try again. If the problem persists, contact OutSystems Support.


As I said earlier, we already contact Outsystems Support and they recommend to use the lower version (1.0.4) instead of (1.0.7) but it prompt same error.



Thank You