how to use output parameter while using database?

while working on the database, each time I get an error to assign an output variable but not able to assign any output parameter?

Hi Anshuman,

You really need to provide more details. What do you mean by "working on the database"? Are you using an Aggregate or an SQL? Can you show us the exact error?

I' am using the SQL query on aggregate.The output from that query is reflecting on my screen, not in my database.

Hi Anshuman,

An SQL query via an Aggregate doesn't change data in the database. It's used exactly for what you see, displaying information from the database on the screen (or to be used in actions). 

If you want to change the data in database you need to use the appropriate actions for these. Each entity (a database table) has actions that allow manipulation of the data. Please review these and use them where you see fit. 

Did you follow any course about OutSystems already? This is should get you up-to speed: https://www.outsystems.com/learn/courses/114/developing-web-apps-outsystems-11/?LearningPathId=2

Hi Anshuman,

Again, please show the error.

Vincent Koning wrote:

Hi Anshuman,

An SQL query via an Aggregate doesn't change data in the database. It's used exactly for what you see, displaying information from the database on the screen (or to be used in actions). 

If you want to change the data in database you need to use the appropriate actions for these. Each entity (a database table) has actions that allow manipulation of the data. Please review these and use them where you see fit. 

Did you follow any course about OutSystems already? This is should get you up-to speed: https://www.outsystems.com/learn/courses/114/developing-web-apps-outsystems-11/?LearningPathId=2

Hi Koning, 

Thanks for the guidelines.