I've been bootstrapping some entities and users to help develop an application. And I had never gotten this error

This shows up while debugging the bootstrap action when I run the block "Excel To Record List." Any idea of what might be causing this?

This is what my excel looks like

And I'm using the following record definition

The weirdest part is that this excel had worked before and only stopped working after I made changes to a different sheet.

I don't know if it's relevant, but I should add that I'm using Google Spreadsheets and downloading it as xlsx.

hi Daniel,

Did you change the name of the sheet? sometimes you change on the excel and don't do the change in the logic and the name needs to be the same you have in the logic

but this error looks something if the identifier:

The problem is that in a sorted list each key needs to be unique. So you need to check that you aren't inserting the same key twice. 

But I saw a similar question and the solution was to refresh the module references and publish again, try and check if will work

Solution

Thank you for your suggestions Carlos tried refreshing the dependencies and that didn't work. I also downloaded and reinstalled that module and that didn't work either.

I confirmed that the name of the sheet is correct and there are no duplicate names on the "Id" column.

I found a workaround that involves downloading the sheet as a separate xlsx file

But if I download the entire sheet, then the problem persists although the sheet has exactly the same name and content.

Solution

For me still look like you are trying to insert an id that already exists on your table on OutSystems, when detect the id exists will give o an error, usually, on bootstrap, you have the entity you try to populate and after an IF that check if the table isn't empty cuz you just want to populate back if the table is empty


check the table you try to populate and take a print from the attribute ID from you table or send the oml file here if you can

from where is coming this value:


usually its a name with the resourcesfolder.NameofFile.Content

check if you arent assign wrong there

Thank you for your comments, Carlos.

The error happens before I try to populate any table. It occurs when ConvertFromExcel is executed. 

If that was the case, then why would it work when I use the single-sheet Excel file?

The "Excel" variable is passed down from the timer

I have attached the oml file. Inside the resources folder, you'll find two xlsx files one is called Examples ID.xlsx, and the other is called Users.xlsx.

The Users.xlsx only has the "User" sheet and doesn't cause any error. The Examples ID.xlsx also has an identic "User" sheet plus additional sheets that, apparently, are causing the problem. I don't understand why.

Try changing the "Excel" parameter on the timer to see the differences.

To catch the error message you need to be in debug mode with "break on all exceptions" or check the error logs in Service Center