[Native Geocoder Plugin] Native Geocoder Plugin not supporting MABS 6.1

Forge Component
(4)
Published on 23 Jul by Henrique Batista
4 votes
Published on 23 Jul by Henrique Batista

We have been using this plugin in one few of the enterprise applications. As per the latest direction of Apple, we tried to update the applications to MABS 6.1. However, it seems that this plugin is not supporting MABS 6.1. We are getting the below error:

error: SWIFT_VERSION '3.0' is unsupported, supported versions are: 4.0, 4.2, 5.0. (in target 'Enterprise_Application' from project 'Enterprise Mobile Banking')** ARCHIVE FAILED **

Error: xcodebuild: Command failed with exit code 65

[2020-04-09T14:49:46.622Z] [ERROR] Build failed with the following error: Error generating application. At least one Cordova plugin used in the build requires Swift but no "Swift Language Version" build setting was defined. Check your plugins configuration.

Is there any workaround available? I request the developer to kindly upgrade the plugin or provide any possible way to upgrade the SWIFT code version.

Solution

Shounak Devbhuti wrote:

We have been using this plugin in one few of the enterprise applications. As per the latest direction of Apple, we tried to update the applications to MABS 6.1. However, it seems that this plugin is not supporting MABS 6.1. We are getting the below error:

error: SWIFT_VERSION '3.0' is unsupported, supported versions are: 4.0, 4.2, 5.0. (in target 'Enterprise_Application' from project 'Enterprise Mobile Banking')** ARCHIVE FAILED **

Error: xcodebuild: Command failed with exit code 65

[2020-04-09T14:49:46.622Z] [ERROR] Build failed with the following error: Error generating application. At least one Cordova plugin used in the build requires Swift but no "Swift Language Version" build setting was defined. Check your plugins configuration.

Is there any workaround available? I request the developer to kindly upgrade the plugin or provide any possible way to upgrade the SWIFT code version.

Hello Shounak Devbhuti,


I had the same problem and this solution works for me.

Install and reference this Plugin: https://www.outsystems.com/forge/component-overview/7208/swift-support-plugin


I hope it works for you too.

Bruno Domingues


Solution

Bruno Domingues wrote:

Shounak Devbhuti wrote:

We have been using this plugin in one few of the enterprise applications. As per the latest direction of Apple, we tried to update the applications to MABS 6.1. However, it seems that this plugin is not supporting MABS 6.1. We are getting the below error:

error: SWIFT_VERSION '3.0' is unsupported, supported versions are: 4.0, 4.2, 5.0. (in target 'Enterprise_Application' from project 'Enterprise Mobile Banking')** ARCHIVE FAILED **

Error: xcodebuild: Command failed with exit code 65

[2020-04-09T14:49:46.622Z] [ERROR] Build failed with the following error: Error generating application. At least one Cordova plugin used in the build requires Swift but no "Swift Language Version" build setting was defined. Check your plugins configuration.

Is there any workaround available? I request the developer to kindly upgrade the plugin or provide any possible way to upgrade the SWIFT code version.

Hello Shounak Devbhuti,


I had the same problem and this solution works for me.

Install and reference this Plugin: https://www.outsystems.com/forge/component-overview/7208/swift-support-plugin


I hope it works for you too.

Bruno Domingues


Thanks a lot...this works like a charm...

Shounak


I have the same issue but this solution don't worked for me on OS 10, there is another way?



Jenifer Abdo wrote:

I have the same issue but this solution don't worked for me on OS 10, there is another way?



 

 What are the steps that you followed?

Regards 

Shounak

Shounak Devbhuti wrote:

Jenifer Abdo wrote:

I have the same issue but this solution don't worked for me on OS 10, there is another way?



 

 What are the steps that you followed?

Regards 

Shounak

 

 Hi! thanks for the replay.


as i'm not using OS 11, i'de copy the Swift Support Plugin source and create an new application on OS 10. i used it as a reference and added the following code in the extensibility settings of the main module.

{
    "preferences": {
        "ios": [
            {
                "name": "UseSwiftLanguageVersion",
                "value": "4"
            }
        ]
    }
}

But i getting the following error on the build log:

 

"Error: Version of installed plugin: "cordova-plugin-add-swift-support@2.0.2" does not satisfy dependency plugin requirement "cordova-plugin-add-swift-support@^1.7.0". Try --force to use installed plugin as dependency."

Hey,

Just uploaded a new version of the plugin, can you give it a try?

the new version its working! 

thanks a lot guys!