List Actions not availbale after upgrade

We've upgrade our DEV environment and all went well.

Accept that for some reason all the (System) action are gone:

Does the System module need to be recompiled or did we miss something?

Thank you

Hi,


Did you follow the upgrade/install  checklist of outsystems to the letter?

Afaik it's pretty complete and if you miss a step, it's possible to get this effect.


for example, I see this in the checklist, did you do that?

Install System Components:
  • Log in to Service Center using your administrator credentials (http://<yourserver>/ServiceCenter)
  • Go to the solutions screen (Factory -> Solutions)
  • Click Upload and Publish a Solution and select the System_Components.osp file in the Platform Server installation directory (e.g.: C:\Program Files\OutSystems\Platform Server\)
  • Click 1-Click Publish, or Prepare Publish if you have 2-Stage deployment active.


see the full checklist here: https://www.outsystems.com/downloads/ScreenDetails.aspx?MajorVersion=11&ReleaseId=19405&ComponentName=Platform+Server


Good luck!

If you are 1000% you followed the checklist, you possibly need to check service center for errors.

In addition to what J. says, the last step of the installation checklist is to republish your whole factory in your DEV environment by creating a solution containing all modules.

If you did not execute this step, you should do so after installing the system components.

Regards,

Nordin

Hi, J

Thank you for your reply.

We did a upgrade from Version 11.0.424.0 to Version 11.7.3 (Build 7036) and we followed all the steps.It's not a major upgrade.

Johan van Rooyen wrote:

Hi, J

Thank you for your reply.

We did a upgrade from Version 11.0.424.0 to Version 11.7.3 (Build 7036) and we followed all the steps.It's not a major upgrade.

True, However in all modes you need to install the system components again :)