Error publishing system components when upgrading to New Platform Version

Hi 


I am experiening the following error when I try to publish the system components.osp after I upgraded from Platform 11.0.424 to 11.7.3



Associating dependencies of 'System_Components'.


Associating dependencies of module 'ADAuthProvider'.


Associating dependencies of module 'appfeedbackapi'.


Associating dependencies of module 'AppFeedbackPlugin'.


Associating dependencies of module 'ChartingServicesCore'.


Associating dependencies of module 'DBCleaner_API'.


Required Permission: You are not allowed to use the Module 'OMLProcessor'.


Associating dependencies of module 'DeviceDatabase'.


Associating dependencies of module 'ECT_Provider'.


Required Permission: You are not allowed to use the Module 'OMLProcessor'.


Associating dependencies of module 'EPA_Taskbox'.


Required Permission: You are not allowed to use the Module 'OMLProcessor'.


Associating dependencies of module 'LDAPAuthProvider'.


Required Permission: You are not allowed to use the Module 'OMLProcessor'.


Associating dependencies of module 'NativeAppBuilder'.


Required Permission: You are not allowed to use the Module 'OMLProcessor'.


Associating dependencies of module 'PerformanceProbe'.


Required Permission: You are not allowed to use the Module 'PlatformLogData'.


Required Permission: You are not allowed to use the Module 'OMLProcessor'.


Associating dependencies of module 'PreviewInDevices'.


Required Permission: You are not allowed to use the Module 'OMLProcessor'.


Associating dependencies of module 'RESTDevService'.


Required Permission: You are not allowed to use the Module 'OMLProcessor'.


Associating dependencies of module 'RichWidgets'.


Associating dependencies of module 'SAPDevService'.


Required Permission: You are not allowed to use the Module 'OMLProcessor'.


Associating dependencies of module 'SecurityUtils'.


Required Permission: You are not allowed to use the Module 'OMLProcessor'.


Associating dependencies of module 'SOAPDevService'.


Required Permission: You are not allowed to use the Module 'OMLProcessor'.


Associating dependencies of module 'TemplateManager'.


Required Permission: You are not allowed to use the Module 'OMLProcessor'.


Associating dependencies of module 'Users'.


Required Permission: You are not allowed to use the Module 'OMLProcessor'.

What could the issue be?


Kind regards

Lucas


Lucas Van Wyk wrote:

Hi 


I am experiening the following error when I try to publish the system components.osp after I upgraded from Platform 11.0.424 to 11.7.3



Associating dependencies of 'System_Components'.


Associating dependencies of module 'ADAuthProvider'.


Associating dependencies of module 'appfeedbackapi'.


Associating dependencies of module 'AppFeedbackPlugin'.


Associating dependencies of module 'ChartingServicesCore'.


Associating dependencies of module 'DBCleaner_API'.


Required Permission: You are not allowed to use the Module 'OMLProcessor'.


Associating dependencies of module 'DeviceDatabase'.


Associating dependencies of module 'ECT_Provider'.


Required Permission: You are not allowed to use the Module 'OMLProcessor'.


Associating dependencies of module 'EPA_Taskbox'.


Required Permission: You are not allowed to use the Module 'OMLProcessor'.


Associating dependencies of module 'LDAPAuthProvider'.


Required Permission: You are not allowed to use the Module 'OMLProcessor'.


Associating dependencies of module 'NativeAppBuilder'.


Required Permission: You are not allowed to use the Module 'OMLProcessor'.


Associating dependencies of module 'PerformanceProbe'.


Required Permission: You are not allowed to use the Module 'PlatformLogData'.


Required Permission: You are not allowed to use the Module 'OMLProcessor'.


Associating dependencies of module 'PreviewInDevices'.


Required Permission: You are not allowed to use the Module 'OMLProcessor'.


Associating dependencies of module 'RESTDevService'.


Required Permission: You are not allowed to use the Module 'OMLProcessor'.


Associating dependencies of module 'RichWidgets'.


Associating dependencies of module 'SAPDevService'.


Required Permission: You are not allowed to use the Module 'OMLProcessor'.


Associating dependencies of module 'SecurityUtils'.


Required Permission: You are not allowed to use the Module 'OMLProcessor'.


Associating dependencies of module 'SOAPDevService'.


Required Permission: You are not allowed to use the Module 'OMLProcessor'.


Associating dependencies of module 'TemplateManager'.


Required Permission: You are not allowed to use the Module 'OMLProcessor'.


Associating dependencies of module 'Users'.


Required Permission: You are not allowed to use the Module 'OMLProcessor'.

What could the issue be?


Kind regards

Lucas


Hi Lucas,


Seems to be related with Lifetime permissions. Are you admin in Lifetime?

Do you have enough permissions to publish these components in your environment?


Hi Lucas,


Please check the solution comments on below post might be that will resolve your problem.

https://www.outsystems.com/forums/discussion/21838/publish-extension-you-dont-have-enough-permissions-over-the-database-connectio/