[Embedded Change Technology] Discussion

[Embedded Change Technology] Discussion

  
Forge Component
(6)
Published on 2011-11-04 by João Portela
6 votes
Published on 2011-11-04 by João Portela
ECT 5.0.4

Can't publish solution, errors regarding missing references. When trying to fix them, opening the ECT_Provider.oml, error saying that espace is marked as system and can not be open with service studio 5.0.2.6 is shown.

solutions?

Hi Bruno,

After publishing the version of the ECT (Embedded Change Technology) available in the Network, try to publish the "Current Running version" via Service Center. The publication of the running version shall refresh the reference of the eSpaces, even the System eSpaces.

Please let me know if you manage to upgrade ECT_Provider espace.

Regards,
João Portela
I've done that ...
ATM only one broken reference with a servicenter table ... espace_version ...

any ideias for this one?
Hi Bruno.

What's the server version you're using? You mentioned SS 5.0.2.6, but what about Service Center?

I would say that, if you are on the latest version of the Platform, and that if it still gives you a broken reference on a system entity, your safest bet is to submit that to our support team - and they'll be the ones who'll better assist that process.

Hope this helps.

Best regards,

Paulo Tavares
Hi Paulo,

I'm using latest (non RC) versions.

SC: 5.0.2.7
SS: 5.0.2.6
IS: 5.0.2.6

still broken with espace_version ...

thanks,

Bruno Rabino

Hi Bruno.

I forgot to say that you should publish the currently running version of the 'Embedded Change Technology' solution (not the espace). Have you tried?

FYI: in 5.0 the publish of the running version of a given solution will refresh the necessary references of the espaces.


regards,
João Portela
Hi João,

I'm doing that ... same error.

Thanks,

Bruno Rabino
Hi Bruno. Before we can help you, there are some things we need to know, such as:
  • Do you have the Enterprise Manager solution published? Which version?
  • Can you access http://your server address/ECT_Provider/Overview.aspx ? What do you get?
Best regards,

Miguel

Hi Bruno,

What Miguel Ventura is trying to say is that although you have broken reference in the Espace_Version entity you probably won't have any problem in runtime. Can you confirm?

By the way, there's a new version of the Embedded Change Technology. Care to test with this one?


Regards,
João Portela

Hello, I just installed ECT version 5.1.4 and I'm getting a broken references error (cannot find extension EnhancedWebReferences).

Its there a problem with the solution file or should this extension be available through some other solution/component?

Best regards,
PC
Hi Pedro,

Today we published a new version of the ECT solution with support to proxies. To do this we added the requirement of the Enhanced Web-References
extension that you can find in the link.

Please publish the Enhanced Web-References extension/solution and republish ECT provider solution.

Please let me know if you have any other problem.


Regards,
João Portela

Hello João and thanks for the promptly anwser.

I'm currently having an issue when deploying Enhanced Web-References extension since the machine where it's being deployed doesn't have .NET Framework 2.0 SDK for the required extension upgrade for version 5.1 (neither has my local machine for that matter)

Is there a better way to upgrade the extension without having to download the 350MB from the .NET SDK and install it?

Best regards,
PC


Hi Pedro,

I've just published a new version of the Enhanced WebReferences extension, for Agile Platform 5.0, that do not requires the .NET SDK in the Platform Server.


Regards,
João Portela
ECT (4.2.15 version) stores wrong information about my eSpace (%ESPACENAME%) and Browser (Used FireFox 4.0.1)


Hi  Matthias,

Sorry for the late reply. I gave a quick look and it looks like you may be using a Platform Server version bellow 4.2.4.51 (which required since ECT version 4.2.12).

Can you confirm which Platofrm Server version are you using?


regards,
João Portela
ECT_Provider Version 6.0.2
 
I'm experiencing a strange behavior. When I'm trying to access the ECT_Provider I get an error in  the errorlog:
FeedbackManager role required
 
But when I'm looking up my Roles in the Users App, I realize it is already assigned. Is this maybe because I'm still using the EnterpriseManager as Userprovider?
 
Regards
Peter
Hi Peter,
I don't think it is related with EnterpriseManager; I'm guessing it might be related to privileges with invalid identifiers.
Try removing and adding the role again (or removing EM's Privilege and adding it again). Logout and login between operations. I think that usualy restores the correct  Ids. Hope it helps
cheers