[CryptoAPI] Crypto api error

Forge Component
(32)
Published on 2019-03-03 by Ricardo Silva
32 votes
Published on 2019-03-03 by Ricardo Silva

Hi,
We have updated our outsystems platform on our Diff environments like DEV, TEST etc. After platform update, when we try to call Crypto api function getting below error - 

 System.IO.FileNotFoundException: Could not load file or assembly 'OutSystems.NssCryptoAPI, Version=11.0.118.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The system cannot find the file specified.

So, we tried with updating dependencies and deploy again but issue not resolved.

The error message reads FileNotFoundException.

Try republishing it in Service Center (NOT via Service Studio). Since Service Studio publishes skips some optimizations.

Swatantra Kumar wrote:

The error message reads FileNotFoundException.

Try republishing it in Service Center (NOT via Service Studio). Since Service Studio publishes skips some optimizations.

Hi Swatantra,

Can you eleborate on your suggestion, what optimizations are being skipped?

Regards,

Daniel


Daniël Kuhlmann wrote:

Swatantra Kumar wrote:

The error message reads FileNotFoundException.

Try republishing it in Service Center (NOT via Service Studio). Since Service Studio publishes skips some optimizations.

Hi Swatantra,

Can you eleborate on your suggestion, what optimizations are being skipped?

Regards,

Daniel


Hi Daniel/Swatantra,

As we have observed that, We have 2 Environments DEV & TEST.
In DEV everything working fine. When I deploy changes to TEST then giving this error.
We had faced same problem at time of last deployment, after deployment it was giving the same but after some time it starts working. And now also we deployed latest changes to TEST and it giving us error. 

Can you please give me more details on this or i need to ask for outsystems support team?



Hi Akash,

Someone had a similar issue in this post and mentions that renaming the module that consumes the extension fixes the error. I’m not sure if you are able to try this out?

@Daniël: João Rosado mentions that publishing via Service Studio skips optimizations over here. But I’m also not sure what those optimizations are and if this is still the case nowadays.

Regards,

Nordin