REST API : 'PUT' data in chucked but failed

I have worked to put data via REST API in chunked mode. Even though i define the content-range and content-length correctly, it often gives me the error 'The Content-Range header length does not match the provided number of bytes"

I tried to do the same way in the postman software and worked successfully.

Anybody can help me what wrong i have made in outsystems REST API?


Hi Jessica,

Is that possible for you to share the sample API or can you share the postman screen shot as well?

Regards,

Manish Jawla

Hi Jessica,

From the rules that I saw Content-Length should have the total size the same as the last part of content-range. And in that case one is 5 and the other is 10.

I checked it here.

Regards,

Marcelo

Hi Marcelo,

As i want to chunk the file content into small units per transfer, i define the content-range to be "bytes 0-4/10" for first uploading...But the result is failed.

If i upload it as a whole, content-range to be "bytes 0-9/10", it works.

What wrong to chunk into the small units?

Thank

Jessica