LSOpenURLsWithRole() failed for the application /Applications/OutSystems Service Stud

I am getting following error , when install and open service studio app into the Mac.


LSOpenURLsWithRole() failed for the application /Applications/OutSystems Service Studio.app/Contents/MacOS/../Resources/OutSystems Service Studio.app with error -10810.

Can you tell us the masOS version you are running and the Service Studio version installed? Please keep in mind that OutSystems Service Studio does not run on macOS Catalina yet. Check this doc and announcement here.


From what I could check on other forums that could be the problem. If you're macOS is not Catalina, it could be because you don't have permissions to open the app (which seems odd since you installed it) or found this

Error -10810
Basically, it means that the Launch Services framework is misbehaving and is encountering errors when trying to launch an application. When you encounter this error message, it is probably best to restart the machine.

Cristiana Umbelino wrote:

Can you tell us the masOS version you are running and the Service Studio version installed? Please keep in mind that OutSystems Service Studio does not run on macOS Catalina yet. Check this doc and announcement here.


From what I could check on other forums that could be the problem. If you're macOS is not Catalina, it could be because you don't have permissions to open the app (which seems odd since you installed it) or found this

Error -10810
Basically, it means that the Launch Services framework is misbehaving and is encountering errors when trying to launch an application. When you encounter this error message, it is probably best to restart the machine.

My Mac Os is Catalina.


Thanks you