[Lottie Animations] Slow animation down

Forge Component
(6)
Published on 2 Jun by Henrique Batista
6 votes
Published on 2 Jun by Henrique Batista

Hi guys,

I've used SetSpeed, 0 stops the animation and -1 makes it go backwards. How to slow it down? Thanks

Hi Janet,

Hi Janet,

You can use the SetSpeed action to a value between 1 and higher to make it faster.

So 1 is normal speed, and 2 is faster and 3 is even faster. Any value between 0 and 1 will slow down the animation speed. This is all defined in the underlying JavaScript library being used by the Forge component.

To fix this do the following:

  1. In  the LotiesAnimations module edit the SetSpeed Client action
  2. Change its input parameter Speed to data type Decimal
  3. Edit the Javascript node in the client action and also change the Speed parameter data type to decimal
  4. 1CP the LottiesAnimations module.
  5. Refresh dependencies where you use the module
  6. Set a value between 0 and 1 to have a slow animation

Regards,

Daniel

Ps. Ideally the team behind this component changes, so that you don't have the need to customized or clone the component.

Solution

Hi Janet and Daniël,

I have a new version in the oven and I'll release a new version with this fix.

Thanks for the feedback!

Cheers

Solution