[Extension FtpWebRequest] OsFtpWebRequest method GetDirAndFileList unable to request to FTP server

Forge Component
(5)
Published on 2019-04-22 by Maycon Oleczinski
5 votes
Published on 2019-04-22 by Maycon Oleczinski

Hi ,

We are using Extension FtpWebRequest to get files from FTP to application server.

Using GetDirAndFileList method to read files.

Its working fine on one server , its sending request to FTP and getting back list of files.

But same code we deployed on other server its returning command ok, but list of files is empty.

From same server we can connect to FTP using CMD, FileZilla and read files. So connection to ftp is ok from server.


We tried to check request trace found that request not going to FTP from Out systems application.

Please let us know what is the issue root cause and resolution for this.

Thanks,


Hi Shirish Bathe,

Did you found some log in the Service Center? 

Hi Shirish Bathe,

Another tip is verify the connectivity to FTP service from the OutSystems Front-End server.

The FTP Service use the 20 and 21 TCP ports, maybe it's not allowed in the infrastructure.

Hi Leandro,

We don't have logs in service center. for FTP issue. Also we tried to connect from FE server using Command line, Power shell to FTP its working fine. Even FileZilla also works on server.

From extension we are getting response command OK , count 0. But there are lot of files on FTP server which is unable to read by extension and download it.

Same extension works on UAT server thats why difficult to understand the issue.

Please assists here as its PROD issue.

Thanks


  

Maybe you can try to set a longer timeout, because of list files size in the extension source code.


Regards,

Leandro.