System User table count for cloned espace

Hi Experts,

I have a weird experience on my systems user table, in my cloned espace they have a different count/output.

The error I'm getting at is that I can't find the email on my first image which exists on the second image but not on the third image.

is this a bug or is there a workaround it?

Filtering on the third image




 

Hi JA,

My guess is you are using different User Providers for your two modules. Please check the value of each module's User Provider property. Unless you are really certain of what you are doing, you should have both set to Users.

Hope this helps!

JA wrote:

Hi Experts,

I have a weird experience on my systems user table, in my cloned espace they have a different count/output.

The error I'm getting at is that I can't find the email on my first image which exists on the second image but not on the third image.

is this a bug or is there a workaround it?

Filtering on the third image




 


Hi,


I think that's very strange behavior, can you please share OML we will try to replicate in our environment.

Hi,


If you don't know where to see what Jorge Martins wrote, take a look at this picture:



Hope this can help.


Best regards,

Ricardo M Pereira

All this information is valid but, like we use to say, the error is between the keyboard and the chair.

You are searching the username in the email field :) 



Hi Nuno,

All this information is valid but, like we use to say, the error is between the keyboard and the chair.

You are searching the username in the email field :) 

You'd be right, if there wasn't a picture earlier showing that email and username have the same values :-p (good catch though!)

From this image I think the username is not that long...


Hi JA,

Just out of curiosity, could you maybe compare the Executed SQL for both, are they being executed on the same database table?


Another thing that comes to mind, is your original application or clone multi tenant ?  I have no experience with it, but maybe someone else on here can say what data will come back if you do 'view data' on a multi tenant application, is there like a default tenant ?  Maybe this is different between your origal module and your clone?

Dorine