Hi 

I am working on mobile app. I have used a REST API to get data from a spreadsheet. In the spreadsheet I have also entered images in a coumn(used https protocol).

I am using a carousel to display images. I am getting error on two fronts

1.)Even though there are two rows I am getting 4 dots in underneath carousel.I have used a list in the carousel to iterate that.

2.)Image is not being display. Instead Broken image symbol is displayed.

Please help.

Hi Shubham,

It will be difficult for people to help you without a module to check, or a better explenation of what you've done so far. The problems alone aren't enough to make a good guess of what goes wrong.

Kilian Hekhuis wrote:

Hi Shubham,

It will be difficult for people to help you without a module to check, or a better explenation of what you've done so far. The problems alone aren't enough to make a good guess of what goes wrong.

 Hi Kilian

 I have used a REST API to get data from the google spreadsheet. In the spreadsheet I have added a column called link in which I am storing images URL. Images are on my google drive . 

When I am trying to use that in my application,even though I have just two links, 4 dots are shown here. Moreover the images is not displayed as appearing in the pic.

I have used Image widget and has set the type as external URL.

If you want more information, please tell.

Hi Shubham,

Have you debugged the app? Checked how many items are in the list of the carousel? Have you checked whether you can access the links from the Excel file yourself? Have you checked whether you can display such an image in a normal image widget?

Kilian Hekhuis wrote:

Hi Shubham,

Have you debugged the app? Checked how many items are in the list of the carousel? Have you checked whether you can access the links from the Excel file yourself? Have you checked whether you can display such an image in a normal image widget?

 Yes I have debugged it.

Length is two.

I can access the link from excel.

Normal image is also not being displayed.

 

Can it be that you can access the images from the Excel because you are logged in on your computer into your Google Drive account, and the images aren't publicly accessible? That would explain why the images aren't showing up.

Shubham Agarwal wrote:

Kilian Hekhuis wrote:

Hi Shubham,

It will be difficult for people to help you without a module to check, or a better explenation of what you've done so far. The problems alone aren't enough to make a good guess of what goes wrong.

 Hi Kilian

 I have used a REST API to get data from the google spreadsheet. In the spreadsheet I have added a column called link in which I am storing images URL. Images are on my google drive . 

When I am trying to use that in my application,even though I have just two links, 4 dots are shown here. Moreover the images is not displayed as appearing in the pic.

I have used Image widget and has set the type as external URL.

If you want more information, please tell.

Hi Shubham,


Can you inspect the code (Ctrl + Shift + I) on the browser to see if there is any erro showing up on the console? Maybe it's not allowing you to connect to the google drive.

Regarding the 4 dots do you think changing the "Mode" Property of the List from "Default" > div could impact something? I am thinking of this solution because it seems it is adding a paragraph to your list, so I am trying to think how we can remove that paragraph. You can also inspect your code on the browser to check what are those 2 extra dots.


Hope it helped,

Clarisse