[Microsoft Office 365 Graph Connector] Microsoft Office 365 Graph Connector Login not working

Forge Component
(3)
Published on 31 Jul by Miguel Sousa
3 votes
Published on 31 Jul by Miguel Sousa

Hi, 

I'm trying to connect using my personal Azure AD but I'm getting the following error in Url. I verified my Client ID, Secret ID, Uname & Password. and your login page /MicrosoftOffice365_Demo/Login.aspx always shows "Invalid username or password" error message.

Kindly help.



error=invalid_request&error_description=AADSTS***%3a+Application+%2728200694-4485-***(OutSystemAppsO365)+is+not+configured+as+a+multi-tenant+application.+Usage+of+the+%2fcommon+endpoint+is+not+supported+for+such+applications+created+after+%2710%2f15%2f2018%27.+Use+a+tenant-specific+endpoint+or+configure+the+application+to+be+multi-tenant.%0d%0aTrace+ID%3a+c752d476-f271-4fea-aa26-d9bde8681600%0d%0aCorrelation+ID%3a+ed8e7592-****%0aTimestamp%3a+2020-07-31+08%3a32%3a22Z





Jim Mathew wrote:

Hi, 

I'm trying to connect using my personal Azure AD but I'm getting the following error in Url. I verified my Client ID, Secret ID, Uname & Password. and your login page /MicrosoftOffice365_Demo/Login.aspx always shows "Invalid username or password" error message.

Kindly help.



error=invalid_request&error_description=AADSTS***%3a+Application+%2728200694-4485-***(OutSystemAppsO365)+is+not+configured+as+a+multi-tenant+application.+Usage+of+the+%2fcommon+endpoint+is+not+supported+for+such+applications+created+after+%2710%2f15%2f2018%27.+Use+a+tenant-specific+endpoint+or+configure+the+application+to+be+multi-tenant.%0d%0aTrace+ID%3a+c752d476-f271-4fea-aa26-d9bde8681600%0d%0aCorrelation+ID%3a+ed8e7592-****%0aTimestamp%3a+2020-07-31+08%3a32%3a22Z





 Hi Jim,

to do login, you need to use the buttons available after the configuration. The integration with the Authentiation System of Outsystems is not available yet.

If this still doesn´t work, feel free to send us another message.


Best Regards,

Nuno Fontoura & Miguel Sousa