Unable to resolve host "HostName": No address associated with hostname .

Hi Getting too many logs as mentioned below in mobile application. Can someone please help me to resolve the issue..Please suggest me what will be the issues as I searched found internet permission issue. but didn't help it more.

Failed to send request due to unexpected error: Unable to resolve host "HostName": No address associated with hostname .


Thanks,

Dileep

Hi,

did you set the hostname?


Cheers

Miguel Verdasca wrote:

Hi,

did you set the hostname?


Cheers

 Hi Miguel, Thanks for reply. we have set the hostname, still we are getting too many logs regarding the same.

Thanks

Dileep

 

Hi Dillep,

and after set the hostname did you publish all applications?


Did you use the SSL Pinning component?


Cheers


Miguel Verdasca wrote:

Hi Dillep,

and after set the hostname did you publish all applications?


Did you use the SSL Pinning component?


Cheers


 Yes we have published all applications and modules.

Is it required to use SSL pining and why we need SSL pinning  I don't have any idea..

Can you please explain little more why we need that


Thanks

Dileep

 

Hi,

No, you do not need to have SSL Pinning, this only serves to make your application more secure, we usually use it in banking applications for example, but this serves to validate the hashes of server certificates (IIS). When you have a problem with the hash json file, usually the crash application (expected behavior), but sometimes it also generates numerous errors in the service center. As without seeing your service center, it is complicated to give you more complete help, it didn't hurt to ask if you had SSL Pinning.


So, you changed the hostname and applied the settings, and republished the solution for the mobile application. Did you configure the APP identifier (bundle) of the mobile application well for both android and google? You have the certificates well generated, and you have the ones for non-productive environments on development servers, with the apps configured for development ... and you have the production certificates in the production environment, with the environment settings as a productive environment (together to the hostname), as well as the settings of the mobile application itself is for App Store / release (depends on whether it is android or ios)? And did you generate a new application, and the APK / IPA that is installed is the last one generated?


Cheers